Bug 22598 - SMP Server locks up/freezes under heavy ethernet load - wait_on_bh error
SMP Server locks up/freezes under heavy ethernet load - wait_on_bh error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-20 14:54 EST by Bill Barthel
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 18:51:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Barthel 2000-12-20 14:54:52 EST
A operational server locks up FTP'ing (locally - 100Mbit) large file or 
many smaller ones (less than one minute), also browsing local 
servers/newsgroups ... at slower T1 speeds, server works fine (accessing 
T1 via the ethernet card). Abit BP6 SMP board with 2 466Mhz processors. 
I've tried two ethernet cards 3com and LinkSys. Problem occurs on both. 
I've looked all over for a solution. I see others having simliar problems 
but, no resolution. 

wait_on_bh error occurs on different irq's, depending on the ethernet card 
used ... others have suggested problems with a particular card ... I've 
tried two with the same problem. The server has been solid (though little 
usuage) to the external world ... local area access (high speed) kills it 
quickly ... I can repeatdly kill the server in a few minutes ... and 
unfortunatly can't update the web server with 100s of pictures ... because 
this problem of locking up ...
Comment 1 Bill Barthel 2000-12-20 16:35:35 EST
The wait_on_bh error shows up on the console ... if X windows is running, the 
mouse locks up ... can not ping server
Comment 2 Alan Cox 2003-06-05 18:51:35 EDT
No similar reports seem with 2.4.x or late 2.2.x kernels so assuming fixed. If
anyone still hits a bug like this open it back up please.

Note You need to log in before you can comment on or make changes to this bug.