Bug 226275 - Merge Review: perl-PDL
Merge Review: perl-PDL
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Package Reviews List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:37 EST by Nobody's working on this, feel free to take it
Modified: 2012-06-04 10:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 12:53:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
orion: fedora‑review+


Attachments (Terms of Use)
patch to devel (3.74 KB, patch)
2007-07-31 17:58 EDT, Orion Poplawski
no flags Details | Diff
patch to look for hdf devel files in the right place (669 bytes, patch)
2007-07-31 17:59 EDT, Orion Poplawski
no flags Details | Diff
patch to fix some tests (1.61 KB, patch)
2007-07-31 17:59 EDT, Orion Poplawski
no flags Details | Diff
patch to find 64-bit libraries for certain modules (1.38 KB, text/x-patch)
2007-07-31 18:00 EDT, Orion Poplawski
no flags Details
Remove -lXext library (399 bytes, patch)
2007-08-01 13:40 EDT, Orion Poplawski
no flags Details | Diff
Patch to spec (2.36 KB, patch)
2007-08-09 16:11 EDT, Orion Poplawski
no flags Details | Diff
patch to fix fortran issues (1.11 KB, patch)
2007-08-09 16:11 EDT, Orion Poplawski
no flags Details | Diff
Updated test patch (1.65 KB, patch)
2007-08-14 17:10 EDT, Orion Poplawski
no flags Details | Diff
patch to support EL-5 GL lib (411 bytes, patch)
2008-01-29 11:39 EST, Orion Poplawski
no flags Details | Diff

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:37:27 EST
Fedora Merge Review: perl-PDL

http://cvs.fedora.redhat.com/viewcvs/devel/perl-PDL/
Initial Owner: rnorwood@redhat.com
Comment 1 Orion Poplawski 2007-07-31 17:55:14 EDT
rpmlint:

W: perl-PDL macro-in-%changelog description

- can be ignored

W: perl-PDL mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 3)

- Fixed in patch

I think the Summary should be changed to something like "The Perl Data Language".

- package meets naming guidelines
- package meets packaging guidelines
- license (GPL/Artistic) OK, text in %doc, matches source
- spec file legible, in am. english
- source matches upstream
- package compiles on devel (x86)
- no unnecessary BR
- no locales
- not relocatable
- owns all directories that it creates
- no duplicate files
- permissions ok
- %clean ok
- macro use consistent
- code, not content
- no need for -docs
- nothing in %doc affects runtime
- no need for .desktop file

Consider including some more files in %doc:
BUGS
Changes
Known_problems
Release_Notes

A number of PDL modules are not being built that could be.  I'll be attaching a
number of patches that enable them as well as getting PDL to build for devel again.
Comment 2 Orion Poplawski 2007-07-31 17:58:22 EDT
Created attachment 160366 [details]
patch to devel

Patch to spec and perl-PDL-settings.patch that:

- turns on 3D/GL
- turns on IO Browser
- changes tabs to spaces
- adds a bunch of BRs to enable more modules
- removes unneeded Provides
Comment 3 Orion Poplawski 2007-07-31 17:59:06 EDT
Created attachment 160367 [details]
patch to look for hdf devel files in the right place
Comment 4 Orion Poplawski 2007-07-31 17:59:37 EDT
Created attachment 160368 [details]
patch to fix some tests
Comment 5 Orion Poplawski 2007-07-31 18:00:09 EDT
Created attachment 160369 [details]
patch to find 64-bit libraries for certain modules
Comment 6 Orion Poplawski 2007-08-01 11:47:47 EDT
Looks like we also need a BR: libGLU-devel
Comment 7 Orion Poplawski 2007-08-01 12:10:52 EDT
Make that BR: libGLU-devel libGL-devel - though GLU depended on GL, but I guess not.
Comment 8 Orion Poplawski 2007-08-01 13:40:08 EDT
Created attachment 160436 [details]
Remove -lXext library

Scratch the BR libGL-devel, real fix is to remove -lXext from the GL linking
options.
Comment 9 Robin Norwood 2007-08-06 13:33:12 EDT
ok, applied your patches, added the additional files to %docs, fixed the
'unescaped % in %changelog' warning, and a non-UTF-8 PDL::Complex.3pm.

However, rpmlint is still complaining about:

W: perl-PDL unversioned-explicit-provides perl(PDL::Config)
etc...

And company.  Wouldn't it be better to version these with the same version as
perl-PDL?

also rpmlint complains about:

W: perl-PDL devel-file-in-non-devel-package
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/PDL/Core/pdlsimple.h
etc...

We could probably move these to a perl-PDL-devel package, if they aren't needed
at runtime.
Comment 10 Orion Poplawski 2007-08-09 16:09:14 EDT
(In reply to comment #9)
> 
> However, rpmlint is still complaining about:
> 
> W: perl-PDL unversioned-explicit-provides perl(PDL::Config)
> etc...
> 
> And company.  Wouldn't it be better to version these with the same version as
> perl-PDL?

Well, the vast majority of the automatic perl provides are unversioned too, so
my take would be to leave the version out for now.

> also rpmlint complains about:
> 
> W: perl-PDL devel-file-in-non-devel-package
> /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/PDL/Core/pdlsimple.h
> etc...
> 
> We could probably move these to a perl-PDL-devel package, if they aren't needed
> at runtime.
> 

Not according to:

http://fedoraproject.org/wiki/PackagingDrafts/Perl#head-b867c6067f009c5ea8f21723d028e8b40fae15c7


Some more stuff:

- I've got perl-ExtUtils-F77 added to Fedora, so we can add:

BuildRequires: perl(ExtUtils::F77)
BuildRequires: gcc-gfortran

I'll also attach a patch that uses the RPM_OPT_FLAGS and -fPIC to compile to
fortran code, and fixes a test for gfortran/f77 compatibility.

This allows PDL::Slatec to build, so we can remove that from the listed Provides.

- Still need BuildRequires: libGLU-devel

- Looks like the License should be re-examined and the tag updated.  Possibly
"GPL+ or Artistic" though some files seem a little different.

- Looks like we need to add Provides: perl(PDL::Graphics::TriD::Objects)

- We need to filter perl(Win32::DDE::Client) from Requires now.

- Don't forget to bump release and add changelog entries!

I'll attach a patch for my spec changes as well.
Comment 11 Orion Poplawski 2007-08-09 16:11:03 EDT
Created attachment 161017 [details]
Patch to spec
Comment 12 Orion Poplawski 2007-08-09 16:11:48 EDT
Created attachment 161018 [details]
patch to fix fortran issues
Comment 13 Robin Norwood 2007-08-10 12:11:54 EDT
Awesome.

Applied your patch, except for the change to the License field.  I've pinged Tom
Callaway to take a look at the license first.  Looks like the standard 'same
terms as perl itself' to me - plus the one public domain image.
Comment 14 Robin Norwood 2007-08-10 12:56:07 EDT
Tom confirmed that you are correct about the license issue, I'll fix it.  Also,
it is failing to build in the buildsystem.  I'll take a look and try to fix it
today.
Comment 15 Orion Poplawski 2007-08-14 17:10:42 EDT
Created attachment 161309 [details]
Updated test patch

Looks like ppc is pickier about test output for some reason.  This updated
patch shuts up xvals.t some more.  With this change it builds for me on ppc and
ppc64.
Comment 16 Robin Norwood 2007-08-15 10:59:19 EDT
Excellent, thanks.  2.4.3-4 should be in rawhide now.  Please take a look.

By the by, are any of these patches submitted upstream?  Looks like some of them
would be appropriate.
Comment 17 Orion Poplawski 2007-08-16 14:59:20 EDT
Looks good to me.  APPROVED.

I haven't sent any patches upstream, I haven't yet managed to subscribe to
PDL-porters.  Looks like that there are similar patches for some of this issues
in upstream CVS.  I would be nice if they did a new release, it's been almost a
full year since the last one.

I'd love to see this make it into EPEL for EL-5 at least.
Comment 18 Robin Norwood 2007-08-16 16:17:07 EDT
"I'd love to see this make it into EPEL for EL-5 at least."

If someone were to file a bug for that, I'd be happy to take a look at it.

I'm guessing the deps will be a pain, though.
Comment 19 Orion Poplawski 2008-01-29 11:39:09 EST
Created attachment 293304 [details]
patch to support EL-5 GL lib

All necessary dependencies for perl-PDL are now in EPEL-5.  The attached patch
is necessary to handle the version of GL in EL-5.  With this patch, it builds
fine for me.
Comment 20 Robin Norwood 2008-01-29 14:00:23 EST
Package Change Request
======================
Package Name: perl-PDL
New Branches: EL-5


There we go.

Orion, would you like to maintain or co-maintain this package in EPEL and/or
Fedora?  I don't actually use it, so you'll probably do a much better job than I
at maintaining it.
Comment 21 Orion Poplawski 2008-01-29 14:04:58 EST
(In reply to comment #20)
> Orion, would you like to maintain or co-maintain this package in EPEL and/or
> Fedora?  I don't actually use it, so you'll probably do a much better job than I
> at maintaining it.

Any/all would be fine.
Comment 22 Robin Norwood 2008-01-29 14:50:37 EST
Ok, here's a new request with that change, too:

Package Change Request
======================
Package Name: perl-PDL
New Branches: EL-5
Updated Fedora Owners: rnorwood, orion
Updated EPEL Owners: rnorwood, orion

Comment 23 Kevin Fenzi 2008-01-30 12:09:20 EST
cvs done.
Comment 24 Robin Norwood 2008-01-30 12:20:17 EST
ok, building for EL5
Comment 25 Robin Norwood 2008-01-30 12:22:20 EST
oops, looks like orion beat me to it.  All yours. :-)
Comment 26 Orion Poplawski 2008-01-30 12:53:29 EST
Build succeeded.  Closing again.  Thanks all!
Comment 27 Petr Pisar 2012-06-04 10:29:15 EDT
Package Change Request
======================
Package Name: perl-PDL
New Branches: 
Owners: 
InitialCC: perl-sig

Please add perl-sig user with watch* permissions only to all Fedora branches.
Comment 28 Jon Ciesla 2012-06-04 10:34:36 EDT
Done.

Note You need to log in before you can comment on or make changes to this bug.