Bug 226308 - natsemi ethernet controller periodically freezes
Summary: natsemi ethernet controller periodically freezes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Andy Gospodarek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-31 20:42 UTC by phil
Modified: 2014-06-29 22:58 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-15 16:19:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0791 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 6 2007-11-14 18:25:55 UTC

Description phil 2007-01-31 20:42:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Description of problem:
periodically my 2nd NIC (a natsemi ethernet card) locks up - a "service network restart" is needed to get it going again.

just before this happens, the following message appears in /var/log/messages

eth1: Oversized(?) Ethernet frame spanned multiple buffers, entry 0x3df74a status 0xd00005f2.

i have a busy server where this happens once or twice a day.

my eth1 reports as following in dmesg

natsemi eth1: NatSemi DP8381[56] at 0xddedf000 (0000:03:0d.0), 00:09:5b:e1:8c:97, IRQ 225, port TP.




Version-Release number of selected component (if applicable):
kernel-2.6.9-42.0.8

How reproducible:
Always


Steps to Reproduce:
1. switch server on
2. wait until 'Oversized(?) Ethernet frame spanned multiple buffers' appears in /var/log/messages
3. observe fault

Actual Results:
the ethernet controller will have locked up, making my web site unavailable

Expected Results:
nothing

Additional info:
i am concerned that this is a bug in the natsemi ethernet driver, having found the following on the web. can someone perhaps check this fix did actually make it into the current rhel4 kernel???


Natsemi oversized packet lockup
Friday, February 10th, 2006

If you're having trouble with a natsemi ethernet controller locked up in Linux after complaining about oversized ethernet frames like this:

Oversized(?) Ethernet frame spanned multiple buffers, entry 0x00ba8b status 0xe0000bd5.

then this patch (or a kernel version which includes it; 2.6.16 or later should) may be useful. The patch is against 2.6.9+ versions of natsemi with NAPI support but doesn't use the NAPI support.

http://www.sirena.org.uk/~broonie/natsemi-rx-lockup-fix.patch

Comment 1 Andy Gospodarek 2007-02-01 04:19:42 UTC
That patch is not currently included in RHEL4.  I will probably build a RHEL4
test kernel that includes that patch in the next couple of days and will post
here when complete.  

Will you be able to install it and test it on your system reasonably soon?


Comment 2 phil 2007-02-01 07:39:48 UTC
Andy-

Yes, I should be able to try this out!

Phil

Comment 3 Andy Gospodarek 2007-02-01 22:04:08 UTC
Test kernels are available here:

http://people.redhat.com/agospoda/#rhel4

Please test them and report back to this BZ.

Comment 4 phil 2007-02-02 11:24:57 UTC
OK I have installed 2.6.9-45.EL.gtest.9smp this morning - currently running
without problems.

Phil

Comment 6 Andy Gospodarek 2007-02-06 15:25:05 UTC
Phil,

Please let me know if you see these hangs with the new kernel.  If not I will
try and push this patch into a future release.  

Thanks for sending it to us.

-andy


Comment 7 phil 2007-02-07 10:18:59 UTC
No problems so far - the server has been running fine since 2007-02-02 06:24
EST, so I'm pretty sure this is an improvement.

Phil

Comment 9 RHEL Product and Program Management 2007-04-12 14:47:31 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 11 RHEL Product and Program Management 2007-04-30 19:01:54 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 12 Jason Baron 2007-06-22 14:24:58 UTC
committed in stream U6 build 55.11. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/


Comment 15 errata-xmlrpc 2007-11-15 16:19:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html



Note You need to log in before you can comment on or make changes to this bug.