This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 226465 - Merge Review: system-config-nfs
Merge Review: system-config-nfs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:06 EST by Nobody's working on this, feel free to take it
Modified: 2009-09-21 16:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.3.33-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 20:36:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
panemade: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:06:23 EST
Fedora Merge Review: system-config-nfs

http://cvs.fedora.redhat.com/viewcvs/devel/system-config-nfs/
Initial Owner: nphilipp@redhat.com
Comment 1 Parag AN(पराग) 2007-09-28 12:59:19 EDT
Preliminary Review:-

rpmlint on SRPM and RPM gave me
-------------------------------------
system-config-nfs.src:18: W: unversioned-explicit-obsoletes redhat-config-nfs
system-config-nfs.src: W: invalid-license GPL
system-config-nfs.noarch: E: script-without-shebang
/usr/share/system-config-nfs/propertiesWindow.py
system-config-nfs.noarch: E: script-without-shebang
/usr/share/system-config-nfs/system-config-nfs.glade
system-config-nfs.noarch: E: script-without-shebang
/usr/share/system-config-nfs/nfsServer.py
system-config-nfs.noarch: E: script-without-shebang
/usr/share/system-config-nfs/nfsExports.py
system-config-nfs.noarch: E: script-without-shebang
/usr/share/system-config-nfs/nfsServerSettings.py
system-config-nfs.noarch: E: script-without-shebang
/usr/share/system-config-nfs/mainWindow.py
system-config-nfs.noarch: W: incoherent-version-in-changelog 1.3.27 1.3.27-1.fc8
system-config-nfs.noarch: W: invalid-license GPL
system-config-nfs.noarch: W: obsolete-not-provided redhat-config-nfs
system-config-nfs.noarch: W: conffile-without-noreplace-flag
/etc/pam.d/system-config-nfs
system-config-nfs.noarch: W: conffile-without-noreplace-flag
/etc/security/console.apps/system-config-nfs
--------------------------------------------------

also,
  good to use %defattr(-,root,root,-)

Update package. Better to provide new SPEC and SRPM links for this package
before actually committing in CVS.
Comment 3 Nils Philippsen 2007-10-11 04:50:02 EDT
(In reply to comment #1)
> Preliminary Review:-
> 
> rpmlint on SRPM and RPM gave me
> -------------------------------------
> system-config-nfs.src:18: W: unversioned-explicit-obsoletes redhat-config-nfs

added version

> system-config-nfs.src: W: invalid-license GPL

checked and changed to GPLv2+

> system-config-nfs.noarch: E: script-without-shebang
> /usr/share/system-config-nfs/propertiesWindow.py
> system-config-nfs.noarch: E: script-without-shebang
> /usr/share/system-config-nfs/system-config-nfs.glade
> system-config-nfs.noarch: E: script-without-shebang
> /usr/share/system-config-nfs/nfsServer.py
> system-config-nfs.noarch: E: script-without-shebang
> /usr/share/system-config-nfs/nfsExports.py
> system-config-nfs.noarch: E: script-without-shebang
> /usr/share/system-config-nfs/nfsServerSettings.py
> system-config-nfs.noarch: E: script-without-shebang
> /usr/share/system-config-nfs/mainWindow.py

made files be installed without executable bits set unless necessary

> system-config-nfs.noarch: W: incoherent-version-in-changelog 1.3.27 1.3.27-1.fc8

added (non-dist-tagged) releases to changelog entries

> system-config-nfs.noarch: W: invalid-license GPL
> system-config-nfs.noarch: W: obsolete-not-provided redhat-config-nfs

idem

> system-config-nfs.noarch: W: conffile-without-noreplace-flag
> /etc/pam.d/system-config-nfs
> system-config-nfs.noarch: W: conffile-without-noreplace-flag
> /etc/security/console.apps/system-config-nfs

aded %config(noreplace)

> --------------------------------------------------
> 
> also,
>   good to use %defattr(-,root,root,-)

changed

> Update package. Better to provide new SPEC and SRPM links for this package
> before actually committing in CVS.

Package is building right now (this is a merge review).


(In reply to comment #2)
> Using xdg-open would be better than htmlview:
> 
> http://www.redhat.com/archives/fedora-devel-list/2007-October/msg00025.html
> http://scop.fedorapeople.org/patches/xdg-utils/system-config-nfs.patch

xdg-open and htmlview are tried in this order, changed requirements suitably for
Fedora >= 7.
Comment 4 Nils Philippsen 2007-10-11 04:51:32 EDT
NB: Ville, is using xdg-open instead of htmlview something required by the
packaging guidelines? Otherwise this would have warranted its own bug.
Comment 5 Nils Philippsen 2007-10-11 04:52:28 EDT
Forgot this: the version building is system-config-nfs-1.3.29-1.fc8.
Comment 6 Ville Skyttä 2007-10-11 11:18:10 EDT
No, xdg-open is not packaging guidelines material at the moment.  Nevertheless
it's something I'd point out during a review of any package where applicable. 
Thanks for using it.
Comment 7 Parag AN(पराग) 2007-10-12 05:33:58 EDT
Thanks for updates.
Current CVS package build fine in mock i386 but rpmlint gave me
system-config-nfs.noarch: E: non-executable-script
/usr/share/system-config-nfs/exports.py 0644
This text file contains a shebang or is located in a path dedicated for
executables, but lacks the executable bits and cannot thus be executed.  If
the file is meant to be an executable script, add the executable bits,
otherwise remove the shebang or move the file elsewhere.

system-config-nfs.noarch: W: obsolete-not-provided redhat-config-nfs
If a package is obsoleted by a compatible replacement, the obsoleted package
must also be provided in order to provide clean upgrade paths and not cause
unnecessary dependency breakage.  If the obsoleting package is not a compatible
replacement for the old one, leave out the provides.

Also,
 Is there any need to use following in SPEC?
   ExclusiveOS: Linux
Comment 8 Parag AN(पराग) 2007-10-12 05:41:37 EDT
I am bit confused whether we really need 
Requires(post): hicolor-icon-theme
Requires(postun): hicolor-icon-theme

because
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#head-7103f6c38d1b5735e8477bdd569ad73ea2c49bda
suggests no such usage of Requires needed.
Comment 9 Nils Philippsen 2007-10-15 05:08:43 EDT
(In reply to comment #7)
> Thanks for updates.
> Current CVS package build fine in mock i386 but rpmlint gave me
> system-config-nfs.noarch: E: non-executable-script
> /usr/share/system-config-nfs/exports.py 0644
> This text file contains a shebang or is located in a path dedicated for
> executables, but lacks the executable bits and cannot thus be executed.  If
> the file is meant to be an executable script, add the executable bits,
> otherwise remove the shebang or move the file elsewhere.

removed exports.py (very old test script which should have been removed for a
long time)

> system-config-nfs.noarch: W: obsolete-not-provided redhat-config-nfs
> If a package is obsoleted by a compatible replacement, the obsoleted package
> must also be provided in order to provide clean upgrade paths and not cause
> unnecessary dependency breakage.  If the obsoleting package is not a compatible
> replacement for the old one, leave out the provides.

This is the case.

> Also,
>  Is there any need to use following in SPEC?
>    ExclusiveOS: Linux

Not that I knew. Removed.

(In reply to comment #8)
> I am bit confused whether we really need 
> Requires(post): hicolor-icon-theme
> Requires(postun): hicolor-icon-theme
> 
> because
>
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#head-7103f6c38d1b5735e8477bdd569ad73ea2c49bda
> suggests no such usage of Requires needed.

removed hicolor-icon-theme requirement, calling gtk-update-icon-cache with full path

system-config-nfs-1.3.30-1.fc8 is building with these changes
Comment 10 Parag AN(पराग) 2007-10-15 06:39:08 EDT
warning: File listed twice:
/usr/share/system-config-nfs/pixmaps/system-config-nfs.png

You need to remove following line from %files in SPEC
%{_datadir}/%{name}/pixmaps/system-config-nfs.png
Comment 11 Nils Philippsen 2007-10-15 12:11:08 EDT
(In reply to comment #10)
> warning: File listed twice:
> /usr/share/system-config-nfs/pixmaps/system-config-nfs.png
> 
> You need to remove following line from %files in SPEC
> %{_datadir}/%{name}/pixmaps/system-config-nfs.png

fixed.

Note that I found that the hicolor-icon-theme requirement is needed because I
ship files beneath /usr/share/icons/hicolor, see:

http://fedoraproject.org/wiki/Packaging/Guidelines#head-a5931a7372c4a00065713430984fa5875513e6d4

I'll re-add it for this and my other packages that have such icons like this
("uncolored", i.e. without pre/post/preun/postun):

Requires: hicolor-icon-theme

system-config-nfs-1.3.31-1.fc8 is building with these changes right now
Comment 12 Parag AN(पराग) 2007-10-16 04:57:52 EDT
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM but Not for RPM.
system-config-nfs.noarch: W: obsolete-not-provided redhat-config-nfs
These messages can be ignored for this package.
+ source files match upstream.
8dae249bcc43a43603f3386d1761b786  system-config-nfs-1.3.32.tar.bz2
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc files present.
+ BuildRequires are proper.
+ defattr usage is correct.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code.
+ no static libraries.
+ no .pc file present.
+ no -devel subpackage exists.
+ no .la files.
+ translations are available.
+ Does owns the directories it creates.
+ no duplicates in %files.
+ file permissions are appropriate.
+ gtk-update-icon-cache scriptlets are used.
+ Desktop files are handled correctly.
+ package system-config-nfs-1.3.32-1.fc8 ->
  Provides: config(system-config-nfs) = 1.3.32-1.fc8
  Requires: /usr/bin/python config(system-config-nfs) = 1.3.32-1.fc8
hicolor-icon-theme nfs-utils pygtk2 pygtk2-libglade python >= 2.0 rhpl usermode
>= 1.36 xdg-utils
+ GUI app.

APPROVED.
Comment 13 Parag AN(पराग) 2007-10-18 04:45:56 EDT
Closing this review as Approved package is already built in rawhide.
Comment 14 Fedora Update System 2007-11-17 00:34:03 EST
system-config-nfs-1.3.33-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-nfs'
Comment 15 Fedora Update System 2007-11-28 20:36:32 EST
system-config-nfs-1.3.33-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.