Bug 226471 - Merge Review: system-config-soundcard
Merge Review: system-config-soundcard
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:07 EST by Nobody's working on this, feel free to take it
Modified: 2009-09-21 16:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 09:10:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:07:18 EST
Fedora Merge Review: system-config-soundcard

http://cvs.fedora.redhat.com/viewcvs/devel/system-config-soundcard/
Initial Owner: stransky@redhat.com
Comment 1 Parag AN(पराग) 2007-09-28 12:26:46 EDT
rpmlint on SRPM and RPM is not clean
-------------------------
system-config-soundcard.src:22: W: unversioned-explicit-obsoletes
redhat-config-soundcard
system-config-soundcard.src:31: W: prereq-use hicolor-icon-theme
system-config-soundcard.src:160: W: macro-in-%changelog preun
system-config-soundcard.src: E: no-cleaning-of-buildroot %install
system-config-soundcard.src: W: invalid-license GPL

system-config-soundcard.noarch: W: no-documentation
system-config-soundcard.noarch: E: script-without-shebang
/usr/share/system-config-soundcard/soundcardBackendKudzu.py
system-config-soundcard.noarch: E: script-without-shebang
/usr/share/system-config-soundcard/soundcardBackend.py
system-config-soundcard.noarch: E: script-without-shebang
/usr/share/system-config-soundcard/soundcardBackendHal.py
system-config-soundcard.noarch: E: script-without-shebang
/usr/share/system-config-soundcard/soundcardBackendSoundCard.py
system-config-soundcard.noarch: E: script-without-shebang
/usr/share/system-config-soundcard/soundcard.py
system-config-soundcard.noarch: E: script-without-shebang
/usr/share/system-config-soundcard/soundcardBackendProc.py
system-config-soundcard.noarch: W: invalid-license GPL
system-config-soundcard.noarch: W: obsolete-not-provided redhat-config-soundcard
system-config-soundcard.noarch: W: conffile-without-noreplace-flag
/etc/pam.d/system-config-soundcard
system-config-soundcard.noarch: W: conffile-without-noreplace-flag
/etc/security/console.apps/system-config-soundcard
---------------------------------------------------------

also,
  1) update buildroot tag as given in
http://fedoraproject.org/wiki/Packaging/Guidelines#head-b4fdd45fa76cbf54c885ef0836361319ab962473
  2) packaging guidelines suggests use of make as 
http://fedoraproject.org/wiki/Packaging/Guidelines#head-525c7d76890cb22df33b759c65c35c82bf434d2e
  3) missing buildroot cleanup in %install. check
http://fedoraproject.org/wiki/Packaging/Guidelines#head-6c809b2e945ca78ae25d040f250be60f73181ef0
  4) any reason for not using macros for following line om %files section
   /usr/bin/system-config-soundcard
   %dir /usr/share/system-config-soundcard
   /usr/share/system-config-soundcard/*
  5) Any reason for commenting %doc COPYING?
  6) good to use %defattr(-,root,root,-)

Update package. Better to provide new SPEC and SRPM links for this package
before actually committing in CVS.
Comment 2 Parag AN(पराग) 2007-10-16 01:20:39 EDT
ping? any update?
Comment 3 Martin Stransky 2007-10-16 05:42:15 EDT
Taking the bug.
Comment 4 Parag AN(पराग) 2007-10-16 06:15:13 EDT
(In reply to comment #3)
> Taking the bug.

sorry?
I saw that
https://admin.fedoraproject.org/pkgdb/packages/name/system-config-soundcard
you are owner for this package.
Then how can you take this bug(which is Package review actually)

As you are the owner for package, I guess you can't assign and review this package.

If that was the case then maintainers could have assigned their own packages to
them and we should not need any review for existing core packages.

I have not seen such case till date since Merge-Review got opened.
Comment 5 Martin Stransky 2007-10-16 06:22:47 EDT
And who is supposed to do that changes in the package? 
Comment 6 Parag AN(पराग) 2007-10-16 06:42:35 EDT
Ofcourse Package maintainer as reviewer is not have acls to commit review changes.

I think you missed to read this page
http://fedoraproject.org/wiki/PackageReviewProcess?highlight=%28reviewprocess%29#head-9d19338d8d18adb89c7e596350c5bfae03f9ec45

There we can find that review process initial steps written as
1. Set the fedora-review flag to ?
2. Assign the bug to yourself.
3. Review the package.


Comment 7 Martin Stransky 2007-10-16 06:57:20 EDT
Okay, I'll assign the bug back to you when I do that changes.
Comment 8 Parag AN(पराग) 2007-10-16 07:54:30 EDT
Thanks for understanding Package review process.
Comment 9 Parag AN(पराग) 2007-10-24 10:06:46 EDT
Ping
Any updates?
Comment 10 Parag AN(पराग) 2007-12-02 08:08:26 EST
Will ping maintainer on fedora-devel after one week if i will not get any
updates here.

Also,
  Maintainer failed to keep promise to give updates by assigning bug to himself
which is not the procedure of fedora-review.
Comment 11 Martin Stransky 2007-12-03 03:42:25 EST
fixes added to system-config-soundcard-2.0.6-12.fc9
Comment 12 Parag AN(पराग) 2007-12-04 07:37:06 EST
other packages are using following in their specs
%config(noreplace) %{_sysconfdir}/pam.d/*
%config(noreplace) %{_sysconfdir}/security/console.apps/*

which your spec lacks thus rpmlint reported warning.
Fix that. 

I think you should look other system-config-* package SPECs which got
successfully reviewed.
Comment 13 Martin Stransky 2007-12-04 08:10:06 EST
Sure, I'll fix it immediately. Sorry for the inconvenience.
Comment 14 Martin Stransky 2007-12-05 06:26:31 EST
fixes added to system-config-soundcard-2.0.6-13.fc9
Comment 15 Parag AN(पराग) 2007-12-06 06:45:26 EST
warning: File listed twice:
/usr/share/system-config-soundcard/system-config-soundcard.logger

and
system-config-soundcard.src:25: W: unversioned-explicit-obsoletes
redhat-config-soundcard
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.


please fix them
Comment 16 Parag AN(पराग) 2007-12-12 09:37:42 EST
Ok. I assume you will take care of above problem in next release. I will now
approve this. In case anyone find above problem is not fixed in next release of
this package, kindly open new bug or mail to fedora-devel list.
I don't want to wait more on this review now.

Will wait for another week for any update otherwise will CLOSE this then.

APPROVED.
Comment 17 Martin Stransky 2007-12-12 10:16:49 EST
*ANY* version of redhat-config-soundcard is really obsoleted.
redhat-config-soundcard just should not be shipped in Fedora.

/usr/share/system-config-soundcard/system-config-soundcard.logger - it's just a
cosmetic error and i'll fix it someday.
Comment 18 Parag AN(पराग) 2007-12-12 11:13:05 EST
Thanks for your quick reply.
unversioned-explicit-obsoletes is ok to ignore.
Comment 19 Parag AN(पराग) 2007-12-18 09:10:28 EST
Almost one week no reply from maintainer.
Time to close this review considering comment#16

Note You need to log in before you can comment on or make changes to this bug.