Bug 226472 - Merge Review: system-config-users
Merge Review: system-config-users
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:07 EST by Nobody's working on this, feel free to take it
Modified: 2009-09-21 16:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: system-config-users-1.2.72-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-18 04:45:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:07:24 EST
Fedora Merge Review: system-config-users

http://cvs.fedora.redhat.com/viewcvs/devel/system-config-users/
Initial Owner: nphilipp@redhat.com
Comment 1 Parag AN(पराग) 2007-09-28 11:53:19 EDT
picking up this for review.

rpmlint on SRPM and RPM gave 
--------------------------------
system-config-users.src:18: W: unversioned-explicit-obsoletes redhat-config-users
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

system-config-users.noarch: E: non-executable-script
/usr/share/system-config-users/system-config-users.py 0644
This text file contains a shebang or is located in a path dedicated for
executables, but lacks the executable bits and cannot thus be executed.  If
the file is meant to be an executable script, add the executable bits,
otherwise remove the shebang or move the file elsewhere.

system-config-users.noarch: W: incoherent-version-in-changelog 1.2.68 1.2.68-1.fc8
The last entry in %changelog contains a version identifier that is not
coherent with the epoch:version-release tuple of the package.

system-config-users.noarch: W: obsolete-not-provided redhat-config-users
If a package is obsoleted by a compatible replacement, the obsoleted package
must also be provided in order to provide clean upgrade paths and not cause
unnecessary dependency breakage.  If the obsoleting package is not a compatible
replacement for the old one, leave out the provides.

system-config-users.noarch: W: conffile-without-noreplace-flag
/etc/pam.d/system-config-users
A configuration file is stored in your package without the noreplace flag.
A way to resolve this is to put the following in your SPEC file:

%config(noreplace) /etc/your_config_file_here


system-config-users.noarch: W: conffile-without-noreplace-flag
/etc/security/console.apps/system-config-users
A configuration file is stored in your package without the noreplace flag.
A way to resolve this is to put the following in your SPEC file:

%config(noreplace) /etc/your_config_file_here


Also,
  1) good to use %defattr(-,root,root,-)
  2) any reason for not using macros for following line om %files section
   /usr/bin/system-config-users
   %dir /usr/share/system-config-users
   /usr/share/system-config-users/*
  3) packaging guidelines suggest use of make as
http://fedoraproject.org/wiki/Packaging/Guidelines#head-525c7d76890cb22df33b759c65c35c82bf434d2e
    
 

Comment 2 Parag AN(पराग) 2007-09-28 11:55:22 EDT
Update package. Better to provide new SPEC and SRPM links for this package
before actually committing in CVS.

Comment 4 Parag AN(पराग) 2007-10-16 00:56:23 EDT
rpmlint on current CVS checkout and built version
system-config-users-1.2.71-1.fc8 gave me

system-config-users.noarch: E: non-executable-script
/usr/share/system-config-users/system-config-users.py 0644
Comment 5 Nils Philippsen 2007-10-16 04:29:01 EDT
should be fixed in system-config-users-1.2.72-1.fc8 which is building right now
Comment 6 Parag AN(पराग) 2007-10-16 04:57:58 EDT
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM but Not for RPM.
system-config-users.noarch: W: obsolete-not-provided redhat-config-users
=>These messages can be ignored for this package.
+ source files match upstream.
7219d727a99e5c8388d631509e8118ef  system-config-users-1.2.72.tar.bz2
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc files present.
+ BuildRequires are proper.
+ defattr usage is correct.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code.
+ no static libraries.
+ no .pc file present.
+ no -devel subpackage exists.
+ no .la files.
+ translations are available.
+ Does owns the directories it creates.
+ no duplicates in %files.
+ file permissions are appropriate.
+ gtk-update-icon-cache scriptlets are used.
+ Desktop files are handled correctly.
+ package system-config-users-1.2.72-1.fc8 ->
  Provides: config(system-config-users) = 1.2.72-1.fc8
  Requires: /bin/sh /usr/bin/pgrep /usr/bin/python config(system-config-users) =
1.2.72-1.fc8 cracklib-python hicolor-icon-theme libuser-python >= 0.56 pygtk2
pygtk2-libglade python >= 2.0 rhpl rpm-python usermode >= 1.36 xdg-utils
+ GUI app.

APPROVED.

Comment 7 Parag AN(पराग) 2007-10-18 04:45:17 EDT
Closing this review as Approved package is already built in rawhide.

Note You need to log in before you can comment on or make changes to this bug.