Bug 22649 - encrypt() function not supported
encrypt() function not supported
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
:
: 23180 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-21 02:42 EST by Kent Howard
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 05:51:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kent Howard 2000-12-21 02:42:07 EST
encrypt() always returns NULL which according to the documentation means
that the crypt() function "is not available on your system".  The MySQL
RPMS from the MySQL authors also appears to exibit this problem.  However
the 3.22.32 RPMS from the authors works fine.
Comment 1 Trond Eivind Glomsrxd 2000-12-26 18:13:12 EST
Confirmed. I'll be looking closer into it (but recommend PostgreSQL anyway :)
Comment 2 Trond Eivind Glomsrxd 2001-01-03 05:51:07 EST
*** Bug 23180 has been marked as a duplicate of this bug. ***
Comment 3 Trond Eivind Glomsrxd 2001-01-08 18:29:45 EST
This should be fixed in 3.23.30-1, available soon from Rawhide:

mysql> select encrypt("hello");
+------------------+
| encrypt("hello") |
+------------------+
| AmIN6keVM5zyk    |
+------------------+
1 row in set (0.00 sec)

mysql>

Note You need to log in before you can comment on or make changes to this bug.