Bug 226513 - Merge Review: units
Merge Review: units
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:13 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-29 23:22:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:13:06 EST
Fedora Merge Review: units

http://cvs.fedora.redhat.com/viewcvs/devel/units/
Initial Owner: harald@redhat.com
Comment 1 Kevin Fenzi 2007-02-07 22:55:42 EST
I'd be happy to review this package... look for a full review in a bit. 
Comment 2 Kevin Fenzi 2007-02-07 23:27:29 EST
OK - Package meets naming and packaging guidelines
OK - Spec file matches base package name.
OK - Spec has consistant macro usage.
OK - Meets Packaging Guidelines.
OK - License (GPL)
OK - License field in spec matches
See below - License file included in package
OK - Spec in American English
OK - Spec is legible.
OK - Sources match upstream md5sum:
e27f580474702e9138b332acbafafe5b  units-1.86.tar.gz
e27f580474702e9138b332acbafafe5b  units-1.86.tar.gz.1
See below - BuildRequires correct
OK - Package has %defattr and permissions on files is good.
OK - Package has a correct %clean section.
See below - Package has correct buildroot
OK - Package is code or permissible content.
OK - Packages %doc files don't affect runtime.

OK - Package compiles and builds on at least one arch.
OK - Package has no duplicate files in %files.
OK - Package doesn't own any directories other packages own.
OK - Package owns all the directories it creates.
See below - No rpmlint output.
OK - final provides and requires are sane:

SHOULD Items:

OK - Should build in mock.
OK - Should build on all supported archs
OK - Should function as described.
OK - Should have dist tag
OK - Should package latest version
0 outstanding bugs - check for outstanding bugs on package.

Issues:

1. Might include in %doc:
ChangeLog COPYING NEWS README

2. Buildroot should be the default one:
      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

3. rpmlint says:
rpmlint on units-1.86-3.fc7.src.rpm
W: units summary-ended-with-dot A utility for converting amounts from one unit
to another.

Suggest: remove . at the end of summary.

W: units no-url-tag

Suggest: add a "URL: http://www.gnu.org/software/units/units.html"

W: units prereq-use /sbin/install-info

Suggest: remove the "Prereq: /sbin/install-info" and replace per
http://www.fedoraproject.org/wiki/Packaging/ScriptletSnippets#head-47896da5fb2662d75deefeb9ba75145a398515db
with
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info

4. Don't use %makeinstall, instead use 'make DESTDIR=$RPM_BUILD_ROOT install'
per
http://www.fedoraproject.org/wiki/PackagingDrafts/MakeInstall

5. Possible missing Buildrequires?

checking for sin... no
checking for tparm in -lncurses... no
checking for tgetent in -ltermcap... no
checking for readline in -lreadline... no

Once you have addressed these items (either by making the suggested changes, or
by explaining why they don't make sense), please reassign this review back 
to me, and change the 'fedora-review' flag back to ? for me to take action. 
Comment 3 Kevin Fenzi 2007-02-23 22:16:38 EST
Resetting flags and such per the new offical review guidelines. 
https://www.redhat.com/archives/fedora-maintainers/2007-February/msg00682.html
Comment 4 Harald Hoyer 2007-03-23 09:41:05 EDT
please check units-1.86-5.fc7
Comment 5 Kevin Fenzi 2007-03-23 23:23:06 EDT
Excellent. I see no further blockers... so this package is APPROVED. 

You can go ahead and close this RAWHIDE once it's been pushed out into rawhide. 
Comment 6 Kevin Fenzi 2007-05-29 23:22:36 EDT
Closing this since it's been checked in and shipped a while back. 

Note You need to log in before you can comment on or make changes to this bug.