Bug 226514 - Merge Review: unix2dos
Merge Review: unix2dos
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:13 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 07:32:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
ruben: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:13:08 EST
Fedora Merge Review: unix2dos

http://cvs.fedora.redhat.com/viewcvs/devel/unix2dos/
Initial Owner: twaugh@redhat.com
Comment 1 Ruben Kerkhof 2007-02-04 08:06:50 EST
Review for release 26.2.2:
* RPM name is OK
* Builds fine in mock
* File list looks OK

Needs work:
* BuildRoot should be %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  (wiki: PackagingGuidelines#BuildRoot)
* BuildRequires: perl should not be included
  (wiki: PackagingGuidelines#Exceptions)
* Preserve timestamps when installing files
* Consider using {?dist} in the Release tag

Notes:
* -Wall is already in RPM_OPT_FLAGS

Rpmlint is not silent:

Source RPM:
W: unix2dos summary-not-capitalized unix2dos - UNIX to DOS text file format converter
     Don't use the name in the Summary
W: unix2dos invalid-license distributable
W: unix2dos no-url-tag
W: unix2dos macro-in-%changelog description
W: unix2dos macro-in-%changelog build
W: unix2dos macro-in-%changelog description

rpmlint of unix2dos-2.2-26:
W: unix2dos summary-not-capitalized unix2dos - UNIX to DOS text file format converter
W: unix2dos invalid-license distributable
W: unix2dos no-url-tag
Comment 2 Tim Waugh 2007-02-06 09:59:05 EST
> * Preserve timestamps when installing files

Not sure what I need to change for this.

> W: unix2dos summary-not-capitalized unix2dos - UNIX to DOS text file format 
> converter
>      Don't use the name in the Summary

Got a better summary I can put in there?

> W: unix2dos invalid-license distributable

It comes with its own COPYRIGHT file, which is not a canned license.  What
should I put for 'License:'?

> W: unix2dos no-url-tag

No upstream any more as far as I can tell.
Comment 3 Ruben Kerkhof 2007-02-06 12:31:31 EST
Hi Tim,

> Not sure what I need to change for this.
To preserve timestamps, use install -p or cp -p

> Got a better summary I can put in there?

"UNIX to DOS text file format converter" sounds good to me
One of the guidelines is to not repeat the name of the package in the summary,
that's all.

> It comes with its own COPYRIGHT file, which is not a canned license.  What
> should I put for 'License:'?

I'm not sure what rpmlint thinks are valid licenses.
Distributable will do.

> No upstream any more as far as I can tell.

That's ok.

Comment 4 Tim Waugh 2007-02-06 12:39:21 EST
Okay, thanks.

Tagged and built as 2.2-27.fc7.
Comment 5 Ruben Kerkhof 2007-02-06 13:52:43 EST
Ah, Distributable (with a capital D) is a valid license. distributable is not.
DEFAULT_VALID_LICENSES in /usr/share/rpmlint/TagsCheck.py contains a list of valid licenses.

If you can change that, it would be nice.
Since I see no further blockers, this package is approved. Please leave the ticket assigned to yourself.
Comment 6 Tim Waugh 2007-02-07 04:59:54 EST
Tagged and built as 2.2-28.fc7.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.