Bug 22655 - ftp program does not work
Summary: ftp program does not work
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ftp   
(Show other bugs)
Version: 7.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-21 11:04 UTC by Marc Schmitt
Modified: 2007-04-18 16:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-17 04:39:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New package (59.49 KB, application/octet-stream)
2001-01-21 15:34 UTC, Bernhard Rosenkraenzer
no flags Details

Description Marc Schmitt 2000-12-21 11:04:24 UTC
Hi there

The ftp client coming with RedHat 7.0 for Alpha seems broken:

[root@test1-a26 rpm]# ftp sunsite.cnlab-switch.ch
Connected to sunsite.cnlab-switch.ch.
220 sunsite.cnlab-switch.ch FTP server ready.
Name (sunsite.cnlab-switch.ch:root): ftp
331 Guest login ok, send your complete e-mail address as password.
Password:
230- Welcome to Swiss SunSITE                 
ftp://sunsite.cnlab-switch.ch/
230- ------------------------                
http://sunsite.cnlab-switch.ch/
230- Thu Dec 21 11:57:56 2000        
mailto:archive@sunsite.cnlab-switch.ch
230-
230- Swiss SunSITE is located in Zurich and operated by
230- - ITA-HSR (Univ of Applied Sciences Rapperswil)
http://www.ita.cnlab.ch/
230- - SWITCH (Swiss Academic & Research Network)      
http://www.switch.ch/
230- Sponsor: Sun Microsystems (Schweiz) AG               
http://www.sun.ch/
230-
230- SunSITE FTP search:
230-         http://sunsite.cnlab-switch.ch:8000/
230-
230- DISCLAIMER: Neither cnlab, SWITCH nor Sun Microsystems are liable
230-             for any use, storage or transmission of any files stored
230-             on this archive.
230-       NOTE: ALL transfers are logged and any misuse will be acted
upon.
230-
230- You are user 8 (max 100), connecting from test1-a26.inf.ethz.ch.
230-
230-Please read the file README
230-  it was last modified on Fri Jan 14 08:54:55 2000 - 342 days ago
230 Guest login ok, access restrictions apply.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> dir
227 Entering Passive Mode (195,176,255,9,71,1)
ftp: connect: Connection refused
ftp> ls
227 Entering Passive Mode (195,176,255,9,191,106)
ftp: connect: Connection refused


I`ve tried several ftp servers, same effect. Those servers work fine when
using the ftp client under RedHat 7.0 for i386.

Thanks for your help.

Regards,
Marc

Comment 1 Patrick Dube 2000-12-21 18:05:34 UTC
It works fine in active mode.  After logging, type passive, this will desable the passive mode.

Comment 2 Patrick Dube 2000-12-21 19:34:43 UTC
I just get the src rpm and compile it without any new options.  It is working!

Comment 3 Larry Fahnoe 2001-01-18 13:55:10 UTC
RedHat 7.0 alpha, ftp-0.17-6, passive mode is broken as shown above.  Active mode works.  Traces show that in passive mode, the client receives and 
acks the server's Entering passive mode... message, but the client never attempts to establish the data connection.

RedHat 7.0 i386, ftp-0.17-6, passive mode does not exhibit the problem.

--Larry


Comment 4 Bernhard Rosenkraenzer 2001-01-21 15:07:00 UTC
Does this still happen in the version from rawhide (0.17-7) with glibc updates?
This looks suspiciously like a glibc or compiler problem if simply rebuilding
fixes it...

Comment 5 Larry Fahnoe 2001-01-21 15:25:52 UTC
Ummmm....rawhide does not have ftp-0.17-7 in either the SRPMS or alpha trees.
The only version in these trees is 0.17-6.

--Larry

Comment 6 Bernhard Rosenkraenzer 2001-01-21 15:34:30 UTC
Created attachment 7928 [details]
New package

Comment 7 Bernhard Rosenkraenzer 2001-01-21 15:35:18 UTC
Rawhide is out of sync with the tree it's built from once again...
Try the package I've attached, it's the one I was talking about.

Comment 8 Larry Fahnoe 2001-01-21 16:01:25 UTC
Bernhard,

The ftp-0.17-7.alpha.rpm you attached solves the passive mode problem.  I am
not able to test active mode due to my firewall.  These systems do have the
current glibc patches applied (2.2-12).

--Larry

Comment 9 comserver 2001-02-17 04:39:04 UTC
FTP on redhat 7 for intel systems does not work.
It is frustrating !!

Comment 10 comserver 2001-02-17 04:39:46 UTC
FTP on redhat 7 for intel systems does not work.
It is frustrating !!

Comment 11 Bernhard Rosenkraenzer 2001-05-17 21:10:24 UTC
alpha: fixed as stated above.
intel: works perfectly for everyone else; make sure you aren't using any odd 
firewall settings.



Note You need to log in before you can comment on or make changes to this bug.