Bug 22657 - uninitialized data left in journal error field after e2fsck
uninitialized data left in journal error field after e2fsck
Status: CLOSED CURRENTRELEASE
Product: Red Hat High Availability Server
Classification: Retired
Component: ext3 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Wil Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-21 06:26 EST by Gerald Britton
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-21 18:45:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Britton 2000-12-21 06:26:33 EST
When running e2fsck on a v1 filesystem, the error field is left in an
uninitialized state
which will then be falsely interpreted as an error in the filesystem.
Comment 1 Stephen Tweedie 2000-12-21 18:45:29 EST
I can't reproduce this using the current e2fsprogs on
ftp.uk.linux.org:/pub/linux/sct/fs/jfs/e2fsprogs/.  Could you see if that helps?
 If not, a little more detail on the versions you are using here would help.
Comment 2 Stephen Tweedie 2001-01-12 08:43:41 EST
I found a place where kernel journal initialisation was not correctly
initialising all journal fields.  Should be fixed in ext3-0.0.5e.

Note You need to log in before you can comment on or make changes to this bug.