Bug 226709 - mkinitrd no longer errors on missing "with" module
Summary: mkinitrd no longer errors on missing "with" module
Status: CLOSED DUPLICATE of bug 249163
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-01 02:55 UTC by Jerry Amundson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 19:33:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jerry Amundson 2007-02-01 02:55:59 UTC
Description of problem:
mkinitrd no longer errors on missing "with" module

Version-Release number of selected component (if applicable):
mkinitrd-5.1.19.0.2-1

How reproducible:
Always

Steps to Reproduce:
1.mkinitrd -f --with=foomod /tmp/initrd.test `uname -r`
2.
3.
  
Actual results:
exit 0

Expected results:
No module foomod found for kernel 2.6.9-34.0.2.ELsmp, aborting.

Additional info:

Comment 1 Jerry Amundson 2007-02-01 03:11:03 UTC
The message
"No module foomod found for kernel 2.6.9-34.0.2.ELsmp, aborting."
is directly from RHEL 4, so it used to work as expected.
But now, some half-assed "--skiperrors" (or allowmissing??) logic is in 
place...

Comment 2 Peter Jones 2007-09-14 19:33:16 UTC
Should be fixed in the current version.

*** This bug has been marked as a duplicate of 249163 ***


Note You need to log in before you can comment on or make changes to this bug.