Bug 226733 - Strange behaviour by latest rawhide intel driver
Strange behaviour by latest rawhide intel driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-01 05:15 EST by Daniel Malmgren
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-23 09:12:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log file (95.06 KB, text/plain)
2007-02-01 05:22 EST, Daniel Malmgren
no flags Details
xorg.conf (2.20 KB, text/plain)
2007-02-01 05:23 EST, Daniel Malmgren
no flags Details
Screen dump (1012.67 KB, image/png)
2007-02-01 05:25 EST, Daniel Malmgren
no flags Details

  None (edit)
Description Daniel Malmgren 2007-02-01 05:15:38 EST
Description of problem:
It seems like the latest xorg intel driver doesn't handle widescreen displays
very well.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-1.6.5-11
beryl-core-0.1.99.2-2.fc7

Actual results:
This is on a laptop running 1280x800 display. Using 1.6.5-10 driver everything
works well. Using 1.6.5-11 it seems like the rightmost piece (might be about 200
pixels) doesn't work very well. No background image is drawed, and the gnome
panel and all it's applet aren't drawed. However, dragging a window into the
area works, although the background isn't redrawn when I drag the window out
again, leaving trace of it left. Rest of the screen looks like expected.

I'll try to get a log file out of it and attach later.
Comment 1 Daniel Malmgren 2007-02-01 05:22:20 EST
Created attachment 147089 [details]
xorg log file
Comment 2 Daniel Malmgren 2007-02-01 05:23:01 EST
Created attachment 147090 [details]
xorg.conf
Comment 3 Daniel Malmgren 2007-02-01 05:25:17 EST
Created attachment 147091 [details]
Screen dump

This is how my screen looks. I pulled the terminal window out to the right and
back again.

Oh, and these are my children on the desktop. Aren't they pretty ;-)
Comment 4 Matěj Cepl 2007-02-01 08:29:49 EST
They certainly are :-). Was that whole purpose of filing this bug?
Comment 5 Daniel Malmgren 2007-02-01 09:24:56 EST
(In reply to comment #4)
> They certainly are :-). Was that whole purpose of filing this bug?

Nope. If that had been the case, I wouldn't have put a terminal over my
daughters face, would I? ;-)

Are you seeing the same behaviour? It would be nice to test with a non
widescreen monitor, but I haven't got any to try right now...
Comment 6 Daniel Malmgren 2007-02-01 09:37:59 EST
Played around a bit with xrandr. It seems that I get this behaviour with all
modes that are "widescreen". For example 1024x768 or 800x600 works (although of
course they aren't pretty).
Comment 7 Adam Jackson 2007-02-01 13:32:33 EST
This is just texture sizing.  Something about the new driver is causing your
maximum texture size to have shrunk from 2048 square to 1024 square.  I don't
see anything obvious that would cause this though...
Comment 8 Daniel Malmgren 2007-02-02 03:07:23 EST
Ok. Anything I can do to trace it? Does this say you anything useful?

$ glxinfo -l|grep TEXTURE_SIZE
libGL warning: 3D driver claims to not support visual 0x4b
    GL_MAX_TEXTURE_SIZE = 2048
    GL_MAX_3D_TEXTURE_SIZE = 128
    GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB = 1024
Comment 9 Daniel Malmgren 2007-02-02 03:17:44 EST
Sorry. It's me being stupid. The above output is from the 1.6.5-10 driver,  the
1.6.5-11 generates:

$ glxinfo -l|grep TEXTURE_SIZE
libGL warning: 3D driver claims to not support visual 0x5b
    GL_MAX_TEXTURE_SIZE = 1024
    GL_MAX_3D_TEXTURE_SIZE = 128
    GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB = 512
Comment 10 Daniel Malmgren 2007-02-02 06:33:51 EST
Found the following:

http://forums.fedoraforum.org/printthread.php?t=138937

I played around with driconf and changed the setting suggested in the url. Now
it looks like this:

$ glxinfo -l|grep TEXTURE_SIZE
libGL warning: 3D driver claims to not support visual 0x5b
    GL_MAX_TEXTURE_SIZE = 2048
    GL_MAX_3D_TEXTURE_SIZE = 256
    GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB = 2048

...but nevertheless my screen looks exactly like before.
Comment 11 Will Woods 2007-02-20 12:18:50 EST
I'm seeing this behavior on an i945-based Mac Mini:

[wwoods@kraid ~]$ glxinfo -l|grep TEXTURE_SIZE
libGL warning: 3D driver claims to not support visual 0x5b
    GL_MAX_TEXTURE_SIZE = 2048
    GL_MAX_3D_TEXTURE_SIZE = 256
    GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB = 2048

Interestingly my desktop is a mere 256x256. Furthermore, I see the same thing on
an i915-based Thinkpad T43, which is *not* widescreen. Even stranger, the
glxinfo output there appears to be accurate:

[wwoods@zebes ~]$ glxinfo -l|grep TEXTURE_SIZE
libGL warning: 3D driver claims to not support visual 0x5b
    GL_MAX_TEXTURE_SIZE = 256
    GL_MAX_3D_TEXTURE_SIZE = 32
    GL_MAX_CUBE_MAP_TEXTURE_SIZE_ARB = 128
Comment 12 Will Woods 2007-02-20 12:28:49 EST
Bah. I forgot that I had set allow_large_textures=2 in .drirc on the Mac Mini,
hence the larger GL_MAX_TEXTURE_SIZE value. Still doesn't work. Removing .drirc
gives TEXTURE_SIZE values identical to the T43.
Comment 13 Will Woods 2007-03-01 14:40:24 EST
Interestingly, setting allow_large_textures=2 in /etc/drirc actually seems to
let compiz work (once you restart X). Unfortunately the performance is total
crap and everything looks to be at 8bpp. Strange.

I guess you need to set it in /etc/drirc so that the X server itself gets that
setting when it gets started by gdm?
Comment 14 Adam Jackson 2007-04-10 18:39:20 EDT
Is this any better with -19? (In tomorrow's push)
Comment 15 Will Woods 2007-04-11 13:33:28 EDT
Works fine for me with xorg-x11-drv-i810-1.6.5-19.fc7. Daniel, can you confirm
that everything's working for you?
Comment 16 Daniel Malmgren 2007-04-12 02:52:04 EDT
I'm sorry, but I can't confirm this. Because of some other bug (that I'm quite
sure is filed somewhere but that I don't seem to find right now) my entire
screen is pure white when i use the intel driver. So I've really got no idea
what works and not beyond the whiteness :-/
Comment 17 Patrick C. F. Ernzer 2007-05-02 07:09:15 EDT
In response to Comment #16:

I guess you mean Bug 238559
As state in the bug, latest package solves the white-screen issue.
Comment 18 Adam Jackson 2007-05-02 17:16:46 EDT
Yeah, white screen of death should be sorted now.
Comment 19 Daniel Malmgren 2007-05-25 05:52:04 EDT
I'm sorry, but no. Latest Rawhide as of today still produces only whiteness if I
use the intel driver...
Comment 20 Daniel Malmgren 2007-08-23 09:12:40 EDT
After updating to 2.1.1 driver this seems to be resorted. Closing.

Note You need to log in before you can comment on or make changes to this bug.