Bug 22682 - sendmail-8.11.1-1 error in sendmail.spec file
Summary: sendmail-8.11.1-1 error in sendmail.spec file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Need Real Name
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-21 18:22 UTC by Jaroslaw Sosnicki
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-21 19:44:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jaroslaw Sosnicki 2000-12-21 18:22:07 UTC
I run in to the problem when upgrading my sendmail. The problem surfaced 
when my server failed to relay messages. Upon imvestigation of the problem 
I found that legacy configuration is not being translated to new format 
due to the bug in sendmail.spec script. 
Ofending line is 231, missing \ in front of $1
Code that works:
for oldfile in relay_allow ip_allow name_allow ; do
    if [ -f /etc/mail/$oldfile ] ; then
        cat /etc/mail/$oldfile | \
                awk "BEGIN { print \"# Entries from obsoleted /etc/mail/
$oldfile\" ;} \
             { print \$1\" RELAY\" }" >> access
       cp /etc/mail/$oldfile /etc/mail/$oldfile.rpmorig
     fi
done

Comment 1 Jaroslaw Sosnicki 2000-12-21 19:44:29 UTC
sendmail-8.11.1-1 is not on beta1 source CD


Note You need to log in before you can comment on or make changes to this bug.