Bug 2269 - procmail-3.10-000lock.patch redundant
procmail-3.10-000lock.patch redundant
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: procmail (Show other bugs)
6.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-19 11:10 EDT by jamie
Modified: 2015-01-07 18:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-31 14:47:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jamie 1999-04-19 11:10:11 EDT
This patch is still distributed with procmail-3.13.1-2.
Thankfully, it is not actually used any more -- the patch
line in the spec file is commented out, though unfortunately
with no comment.

I suggest a comment at least, pointing out just how bad it
would be to disable fcntl() locking now that kernel 2.2 uses
that for NFS.  (It's used for cache coherency as well as
locking with the 2.2 NFS client).

I suggest the patch be removed, or even replaced with one
that explicitly uses "100" instead of "000".
Comment 1 Jeff Johnson 1999-05-31 14:47:59 EDT
The patch is supplied as a reference to people who might be
trying to use later versions of a package on earlier versions
of an operating system.

As for locking, Red Hat since 5.2 uses *only* fcntl locking for
incoming mail.

Note You need to log in before you can comment on or make changes to this bug.