Bug 226926 - Lack of address info in UI causing ISE
Lack of address info in UI causing ISE
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Sanda
joseph canton
https://rhn.webqa.redhat.com/rhn/acco...
:
: 230272 (view as bug list)
Depends On: 240329
Blocks: 239809
  Show dependency treegraph
 
Reported: 2007-02-01 20:31 EST by Partha Aji
Modified: 2007-07-25 14:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.0.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 14:49:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Partha Aji 2007-02-01 20:31:50 EST
Description of problem:
Clicking on address ui causes an ISE for certain users..

Version-Release number of selected component (if applicable): rhn 500 hosted


How reproducible: for some users


Steps to Reproduce:
1. Open yasql on web qa
2. Run the following sql
select wc.id, wc.login, wc.password from web_contact wc where rownum <20 and not
exists (select 1 from web_user_site_info si where si.web_user_id = wc.id)
3. This should get about 20 records with an assortment of login names and passwords
4. Now go to https://rhn.webqa.redhat.com/rhn/account/Addresses.do and try one
of the login credentials that was obtained from  step 2
  
Actual results:
ISE

Expected results:
Page showing the address of the user...

Additional info:
Same results occur with https://rhn.webqa.redhat.com/rhn/users/Addresses.do?uid=
Issue is to do with this weird creation of certain users on prod who do not for
some reason have a row in web_user_site_info table.. This causes all sorts of
exceptions while retrieving addresses..


stack trace if some is interested...

2007-02-01 19:59:31,558 [TP-Processor1] DEBUG
net.rkbloom.logdriver.LogPreparedStatement - executing PreparedStatement:
'select WEB_USER_SITE_INFO_ID_SEQ.nextval from dual' with bind parameters: {}
2007-02-01 19:59:31,585 [TP-Processor1] DEBUG
net.rkbloom.logdriver.LogPreparedStatement - executing PreparedStatement:
'insert into WEB_USER_SITE_INFO (address1, address2, city, state, zip, country,
phone, fax, is_po_box, type, id) values (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)' with
bind parameters: {1= , 2= , 3= , 4= , 5= , 6= , 7= , 8= , 9=0, 10=M, 11=8721956}
2007-02-01 19:59:31,605 [TP-Processor1] WARN 
org.hibernate.util.JDBCExceptionReporter - SQL Error: 1400, SQLState: 23000
2007-02-01 19:59:31,605 [TP-Processor1] ERROR
org.hibernate.util.JDBCExceptionReporter - ORA-01400: cannot insert NULL into
("WEB"."WEB_CONTACT_LOG"."ID")
ORA-06512: at "WEB.WEB_SITE_INFO_UPD_INS_LOG", line 3
ORA-04088: error during execution of trigger 'WEB.WEB_SITE_INFO_UPD_INS_LOG'

2007-02-01 19:59:31,605 [TP-Processor1] ERROR
org.hibernate.event.def.AbstractFlushingEventListener - Could not synchronize
database state with session
org.hibernate.exception.ConstraintViolationException: could not insert:
[com.redhat.rhn.domain.user.AddressImpl]
	at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:71)
	at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelper.java:43)
	at
org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2078)
	at
org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2427)
	at org.hibernate.action.EntityInsertAction.execute(EntityInsertAction.java:51)
	at org.hibernate.engine.ActionQueue.execute(ActionQueue.java:248)
	at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:232)
	at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:139)
	at
org.hibernate.event.def.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:297)
	at
org.hibernate.event.def.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:27)
	at org.hibernate.impl.SessionImpl.flush(SessionImpl.java:985)
	at
com.redhat.rhn.common.db.datasource.CachedStatement.stealConnection(CachedStatement.java:691)
	at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:325)
	at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:315)
	at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:243)
	at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:232)
	at com.redhat.rhn.common.db.datasource.SelectMode.execute(SelectMode.java:100)
	at com.redhat.rhn.domain.rhnset.RhnSetFactory.lookupByLabel(RhnSetFactory.java:65)
	at com.redhat.rhn.manager.rhnset.RhnSetManager.findByLabel(RhnSetManager.java:40)
	at com.redhat.rhn.manager.rhnset.RhnSetDecl.lookup(RhnSetDecl.java:232)
	at
com.redhat.rhn.frontend.taglibs.SystemSetDisplayTag.doEndTag(SystemSetDisplayTag.java:43)
	at
org.apache.jsp.WEB_002dINF.includes.header_jsp._jspx_meth_rhn_setdisplay_0(header_jsp.java:624)
	at
org.apache.jsp.WEB_002dINF.includes.header_jsp._jspx_meth_rhn_require_8(header_jsp.java:585)
	at org.apache.jsp.WEB_002dINF.includes.header_jsp._jspService(header_jsp.java:159)
	at org.apache.jasper.runtime.HttpJspBase.service(Unknown Source)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
	at org.apache.jasper.servlet.JspServletWrapper.service(Unknown Source)
	at org.apache.jasper.servlet.JspServlet.serviceJspFile(Unknown Source)
	at org.apache.jasper.servlet.JspServlet.service(Unknown Source)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:704)
	at
org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:590)
	at
org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:510)
	at org.apache.jasper.runtime.JspRuntimeLibrary.include(Unknown Source)
	at
org.apache.jsp.WEB_002dINF.decorators.layout_005fc_jsp._jspx_meth_html_html_0(layout_005fc_jsp.java:142)
	at
org.apache.jsp.WEB_002dINF.decorators.layout_005fc_jsp._jspService(layout_005fc_jsp.java:84)
	at org.apache.jasper.runtime.HttpJspBase.service(Unknown Source)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
	at org.apache.jasper.servlet.JspServletWrapper.service(Unknown Source)
	at org.apache.jasper.servlet.JspServlet.serviceJspFile(Unknown Source)
	at org.apache.jasper.servlet.JspServlet.service(Unknown Source)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:704)
	at
org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:590)
	at
org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:510)
	at
com.opensymphony.module.sitemesh.filter.PageFilter.applyDecorator(PageFilter.java:181)
	at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:65)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:51)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:95)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:98)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at
org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
	at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
	at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
	at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
	at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
	at java.lang.Thread.run(Thread.java:797)
Caused by: 
java.sql.SQLException: ORA-01400: cannot insert NULL into
("WEB"."WEB_CONTACT_LOG"."ID")
ORA-06512: at "WEB.WEB_SITE_INFO_UPD_INS_LOG", line 3
ORA-04088: error during execution of trigger 'WEB.WEB_SITE_INFO_UPD_INS_LOG'

	at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
	at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:331)
	at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:288)
	at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:743)
	at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:216)
	at
oracle.jdbc.driver.T4CPreparedStatement.executeForRows(T4CPreparedStatement.java:955)
	at
oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1168)
	at
oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3285)
	at
oracle.jdbc.driver.OraclePreparedStatement.executeUpdate(OraclePreparedStatement.java:3368)
	at
net.rkbloom.logdriver.LogPreparedStatement.executeUpdate(LogPreparedStatement.java:92)
	at
com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.executeUpdate(NewProxyPreparedStatement.java:1986)
	at org.hibernate.jdbc.NonBatchingBatcher.addToBatch(NonBatchingBatcher.java:23)
	at
org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2062)
	... 83 more
2007-02-01 19:59:31,664 [TP-Processor1] ERROR
com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction.
Rolling back
org.apache.jasper.JasperException: HibernateException executing CachedStatement
	at org.apache.jasper.servlet.JspServletWrapper.service(Unknown Source)
	at org.apache.jasper.servlet.JspServlet.serviceJspFile(Unknown Source)
	at org.apache.jasper.servlet.JspServlet.service(Unknown Source)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:704)
	at
org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:590)
	at
org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:510)
	at org.apache.jasper.runtime.JspRuntimeLibrary.include(Unknown Source)
	at
org.apache.jsp.WEB_002dINF.decorators.layout_005fc_jsp._jspx_meth_html_html_0(layout_005fc_jsp.java:142)
	at
org.apache.jsp.WEB_002dINF.decorators.layout_005fc_jsp._jspService(layout_005fc_jsp.java:84)
	at org.apache.jasper.runtime.HttpJspBase.service(Unknown Source)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
	at org.apache.jasper.servlet.JspServletWrapper.service(Unknown Source)
	at org.apache.jasper.servlet.JspServlet.serviceJspFile(Unknown Source)
	at org.apache.jasper.servlet.JspServlet.service(Unknown Source)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:704)
	at
org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:590)
	at
org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:510)
	at
com.opensymphony.module.sitemesh.filter.PageFilter.applyDecorator(PageFilter.java:181)
	at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:65)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:51)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:95)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:98)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186)
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157)
	at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at
org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
	at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
	at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
	at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
	at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683)
	at java.lang.Thread.run(Thread.java:797)
2007-02-01 19:59:31,700 [TP-Processor1] DEBUG net.rkbloom.logdriver.LogStatement
- Executing: ALTER SESSION SET OPTIMIZER_GOAL=RULE
2007-02-01 19:59:31,703 [TP-Processor1] DEBUG
net.rkbloom.logdriver.LogPreparedStatement - executing PreparedStatement:
'select legacyrhnu0_.id as id69_3_, legacyrhnu0_.login as login69_3_,
legacyrhnu0_.login_uc as login3_69_3_, legacyrhnu0_.password as password69_3_,
legacyrhnu0_.created as created69_3_, legacyrhnu0_.modified as modified69_3_,
legacyrhnu0_.org_id as org7_69_3_, personalin1_.web_user_id as web1_67_0_,
personalin1_.prefix as prefix67_0_, personalin1_.first_names as first3_67_0_,
personalin1_.last_name as last4_67_0_, personalin1_.company as company67_0_,
personalin1_.title as title67_0_, personalin1_.phone as phone67_0_,
personalin1_.fax as fax67_0_, personalin1_.email as email67_0_,
personalin1_.created as created67_0_, personalin1_.modified as modified67_0_,
orgimpl2_.id as id136_1_, orgimpl2_.name as name136_1_, orgimpl2_.password as
password136_1_, orgimpl2_.oracle_customer_id as oracle4_136_1_,
orgimpl2_.oracle_customer_number as oracle5_136_1_, orgimpl2_.customer_type as
customer6_136_1_, orgimpl2_.created as created136_1_,
orgimpl2_.credit_application_completed as credit8_136_1_, orgimpl2_.modified as
modified136_1_, entitlemen3_.org_id as org1_5_, orgentitle4_.id as entitlem2_5_,
orgentitle4_.id as id140_2_, orgentitle4_.label as label140_2_,
orgentitle4_.name as name140_2_, orgentitle4_.created as created140_2_,
orgentitle4_.modified as modified140_2_ from WEB_CONTACT legacyrhnu0_ inner join
WEB_USER_PERSONAL_INFO personalin1_ on legacyrhnu0_.id=personalin1_.web_user_id
inner join WEB_CUSTOMER orgimpl2_ on legacyrhnu0_.org_id=orgimpl2_.id left outer
join rhnOrgEntitlements entitlemen3_ on orgimpl2_.id=entitlemen3_.org_id left
outer join RHNORGENTITLEMENTTYPE orgentitle4_ on
entitlemen3_.entitlement_id=orgentitle4_.id where legacyrhnu0_.id=?' with bind
parameters: {1=4730329}
2007-02-01 19:59:31,707 [TP-Processor1] DEBUG
net.rkbloom.logdriver.LogPreparedStatement - executing PreparedStatement:
'select orgquota0_.org_id as org1_141_2_, orgquota0_.total as total141_2_,
orgquota0_.bonus as bonus141_2_, orgquota0_.used as used141_2_,
orgquota0_.created as created141_2_, orgquota0_.modified as modified141_2_,
orgimpl1_.id as id136_0_, orgimpl1_.name as name136_0_, orgimpl1_.password as
password136_0_, orgimpl1_.oracle_customer_id as oracle4_136_0_,
orgimpl1_.oracle_customer_number as oracle5_136_0_, orgimpl1_.customer_type as
customer6_136_0_, orgimpl1_.created as created136_0_,
orgimpl1_.credit_application_completed as credit8_136_0_, orgimpl1_.modified as
modified136_0_, entitlemen2_.org_id as org1_4_, orgentitle3_.id as entitlem2_4_,
orgentitle3_.id as id140_1_, orgentitle3_.label as label140_1_,
orgentitle3_.name as name140_1_, orgentitle3_.created as created140_1_,
orgentitle3_.modified as modified140_1_ from rhnOrgQuota orgquota0_ inner join
WEB_CUSTOMER orgimpl1_ on orgquota0_.org_id=orgimpl1_.id left outer join
rhnOrgEntitlements entitlemen2_ on orgimpl1_.id=entitlemen2_.org_id left outer
join RHNORGENTITLEMENTTYPE orgentitle3_ on
entitlemen2_.entitlement_id=orgentitle3_.id where orgquota0_.org_id=?' with bind
parameters: {1=5253640}
2007
Comment 1 Mike McCune 2007-02-01 20:40:46 EST
For RHN 500 we are going to remove the ability to view Address information in
the RHN UI (in hosted and satellite).  Storing and viewing address information
is largely useless and should be managed as part of the UGC application.  We
should only store/edit/manage RHN specific information.

This means:

1) Remove the 'Addresses' tab for sub users:

(login as sat-installer/redhat)

https://rhn.webqa.redhat.com/rhn/users/Addresses.do?uid=4603895

2) Remove the Address tab from Your Account:

https://rhn.webqa.redhat.com/rhn/account/Addresses.do

We will leave the Address fields on the Sub-User creation page:

https://rhn.webqa.redhat.com/rhn/users/CreateUser.do?account_type=into_org

because these fields are required for UGC/www

Comment 2 Mike McCune 2007-02-15 12:04:18 EST
Not going to remove addresses in 500.  No time left.
Comment 3 John Sanda 2007-06-18 20:58:17 EDT
All user management code with the exception of subuser creation is being removed
from RHN since the UGC handles it.
Comment 4 John Sanda 2007-06-18 22:48:04 EDT
*** Bug 230272 has been marked as a duplicate of this bug. ***
Comment 5 John Sanda 2007-06-18 23:15:57 EDT
Test Plan:

1. Log into webqa as an org admin.
2. Verify that the Address tab from Your Account has been removed.
3. In a browser go to https://rhn.webqa.redhat.com/rhn/account/UserDetails.do.
3.1. On the menu on the left under Your Account, verify that you only see
Account Deactivation.
4. Navigating to https://rhn.webqa.redhat.com/rhn/account/Addresses.do should
result in a Page Not Found.
5. Verify that the Addresses tab for sub-users has been removed.
6. In a browser, go to
https://rhn.webqa.redhat.com/rhn/users/UserDetails.do?uid=4603895.
6.1 username: sat-installer / password: redhat
7. Navigating directly to
https://rhn.webqa.redhat.com/rhn/users/Addresses.do?uid=4603895 with
username/password from 6.1 should result in a Page Not Found.
8. Verify that sub-user creation still works.
8.1 Navigate to
https://rhn.webqa.redhat.com/rhn/users/CreateUser.do?account_type=into_org
8.2 Create a sub-user and verify that you can log in with the new user.
Comment 6 John Sanda 2007-06-19 00:10:31 EDT
Moving backed to ASSIGNED because 6 and 7 in the test plan fail.
Comment 7 joseph canton 2007-06-27 15:34:16 EDT
Moving back to ASSIGNED because 8 in test plan fail.  Error page received is
"Service Error - The server was unable to connect to the service..."
Url showing was https://rhn.webqa.redhat.com/rhn/newlogin/CreateUserSubmit.do.

Service error occured on two different accounts. The urls  
http://bsserver1.app.oap.dev.redhat.com/svc/user/UserService?wsdl and
http://bsserver1.app.oap.dev.redhat.com:9090/svc/user/UserService?wsdl both
responded, so I think the service is running. (I'm thinking the UserService
creates the new users).

Comment 8 John Sanda 2007-06-27 15:52:51 EDT
The stack trace in the logs contains,

Caused by: org.xml.sax.SAXException: Invalid element in
com.redhat.common.model.StreetAddress - poBox
        at
org.apache.axis.encoding.ser.BeanDeserializer.onStartChild(BeanDeserializer.java:258)
        at
org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1035)
        at
org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:165)
        at
org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:1141)
        at org.apache.axis.message.RPCElement.deserialize(RPCElement.java:236)
        at org.apache.axis.message.RPCElement.getParams(RPCElement.java:384)
        at org.apache.axis.client.Call.invoke(Call.java:2467)
        ... 64 more

There is a known issue with Axis 1 with the BeanDeserializer class that has
resulted in us having to regularly update the user service wsdl for additive
changes that do not break backwards compatibility. I will test locally, using
the user service in webqa.
Comment 9 John Sanda 2007-07-03 13:18:08 EDT
Checked in a change under revision 117271. After creating the user, we were
querying the user service  for the user. We were then querying against the
database for the user. (The user should exist in both places) I removed the
query against the user service. This ought to get us around the deserialization
bug (https://issues.apache.org/jira/browse/AXIS-1761) as we are no longer
reading from the service.
Comment 10 joseph canton 2007-07-03 16:31:36 EDT
test plan items 1 through 8 appear to work correctly.  I also checked login of
user  houki-s, and movielover. Both of these accounts were selected by the sql
shown in bug description above. both logged in without exception.

moving to verified.
Comment 11 James Bowes 2007-07-25 11:18:34 EDT
rhn502 released.

Note You need to log in before you can comment on or make changes to this bug.