Bug 226945 - GUI X-Window will always too big to exceed the screen band width
GUI X-Window will always too big to exceed the screen band width
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-02 02:03 EST by Spencer Tsai
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 09:17:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
MGA newest vendor driver package for x86-64. (3.60 MB, application/x-gzip)
2007-02-02 02:03 EST, Spencer Tsai
no flags Details
MGA newest vendor driver package for x86 (32bit). (3.37 MB, application/x-gzip)
2007-02-02 02:16 EST, Spencer Tsai
no flags Details
FC6 original (without manual config) xorg.conf after finished installation. (565 bytes, application/octet-stream)
2007-02-06 11:16 EST, Spencer Tsai
no flags Details
FC6 original (without manual config) Xorg.0.log after finished installation. (63.79 KB, application/octet-stream)
2007-02-06 11:18 EST, Spencer Tsai
no flags Details
FC6 xorg.conf after finished VGA driver update and configuration. (966 bytes, application/octet-stream)
2007-02-06 11:19 EST, Spencer Tsai
no flags Details
FC6 Xorg.0.log after finished VGA driver update and configuration. (53.45 KB, application/octet-stream)
2007-02-06 11:20 EST, Spencer Tsai
no flags Details

  None (edit)
Description Spencer Tsai 2007-02-02 02:03:24 EST
Description of problem:
1. GUI X-Window will always too big to exceed the screen band width during
installation. boot command "linux resolution=800x600" is useless.
2. After installation, X-Window display is abnormal.
3. Both FC6 x86 and x86-64 have the some error situation.

Platform: Gateway E-9422R and E-9522R (AMD Opteron system)
VGA chipset: Maxtrox Inc, MGA G200e [Pilot] ServerEngines (SEP1) (rev02)

Version-Release number of selected component (if applicable):
xorg-x11-drv-mga-1.4.2-1.fc6.x86_64.rpm

How reproducible:
Always.

Steps to Reproduce:
1. CD/DVD boot or PXE boot to install FC6
2. GUI Installation window over screen band width.
3. After finished installation, X-Window display also looks abnormal.
  
Actual results:


Expected results:


Additional info:
1. RHEL5 Beta2 has the same VGA display error situation.
2. In FC6, after updated vendor driver the X-Window display will become
normally. But about OS installation stage, still no resolution.
Comment 1 Spencer Tsai 2007-02-02 02:03:26 EST
Created attachment 147190 [details]
MGA newest vendor driver package for x86-64.
Comment 2 Spencer Tsai 2007-02-02 02:16:48 EST
Created attachment 147191 [details]
MGA newest vendor driver package for x86 (32bit).
Comment 3 Matěj Cepl 2007-02-05 19:06:50 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Spencer Tsai 2007-02-06 11:16:51 EST
Created attachment 147481 [details]
FC6 original (without manual config) xorg.conf after finished installation.
Comment 5 Spencer Tsai 2007-02-06 11:18:21 EST
Created attachment 147482 [details]
FC6 original (without manual config) Xorg.0.log after finished installation.
Comment 6 Spencer Tsai 2007-02-06 11:19:34 EST
Created attachment 147483 [details]
FC6 xorg.conf after finished VGA driver update and configuration.
Comment 7 Spencer Tsai 2007-02-06 11:20:49 EST
Created attachment 147484 [details]
FC6 Xorg.0.log after finished VGA driver update and configuration.
Comment 8 Spencer Tsai 2007-02-06 11:38:41 EST
(In reply to comment #3)
> Thanks for the bug report.  We have reviewed the information you have provided
> above, and there is some additional information we require that will be helpful
> in our diagnosis of this issue.
> 
> Please attach your X server config file (/etc/X11/xorg.conf) and X server log
> file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
> attachments using the bugzilla file attachment link below.
> 
> Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
> let X11 autodetect your display and video card? Attach to this bug
> /var/log/Xorg.0.log from this attempt as well, please.
> 
> We will review this issue again once you've had a chance to attach this
information.
> 
> Thanks in advance.

Please reference to the new attached files for your requirement.
Basically, FC6 i386/X86-64 and RHEL5 beta2 i386/X86-64 have the same VGA issue.
Thank you.
Comment 9 Spencer Tsai 2007-02-07 09:38:54 EST
Please reference to Bug report 226948.
RHEL5-beta2 has the same VGA issue.
But RHEL5-RC1 has been fixed this problem.
Suggest reference to RHEL5-RC1 to fix this issue.
Thank you. 
Comment 10 Matěj Cepl 2007-05-24 09:46:57 EDT
Reporter, could you just confirm that this bug is still reproducable with the
currently updated FC6 on your computer? Sorry for the delay in resolving this issue.
Comment 11 Spencer Tsai 2007-05-25 01:10:24 EDT
Tested with currently updated package: xorg-x11-drv-mga-1.4.5-2.fc6.x86_64.rpm,
The same error situation still remains.
Error:
    1. GUI display still exceed CRT Monitor Band width.
    2. After FC6 installation, updated mga rpm driver,
       GUI display still abnormal.
Comment 12 Matěj Cepl 2007-12-10 04:24:01 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 13 Spencer Tsai 2007-12-10 05:03:56 EST
Fedora7 and Fedora8 X-Window display are normally with MGA driver.
This error only shows uopn Fedora Core 6.
Comment 14 Matěj Cepl 2007-12-11 09:17:51 EST
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.