Bug 226950 - Can't install OS on ATI SB600 chipset with legacy IDE mode
Summary: Can't install OS on ATI SB600 chipset with legacy IDE mode
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Prarit Bhargava
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: OtherQA
: 228400 234245 (view as bug list)
Depends On:
Blocks: 221318 227594 227595
TreeView+ depends on / blocked
 
Reported: 2007-02-02 07:45 UTC by Xin-Yun Liu (Wolke Liu)
Modified: 2009-06-19 14:19 UTC (History)
8 users (show)

Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 16:19:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SB 600 IDE controller only has one channel (988 bytes, patch)
2007-02-02 07:48 UTC, Xin-Yun Liu (Wolke Liu)
no flags Details | Diff
fix udma mode issue (935 bytes, patch)
2007-02-02 09:27 UTC, Xin-Yun Liu (Wolke Liu)
no flags Details | Diff
RHEL4.6: fix for this issue (1.42 KB, patch)
2007-07-05 15:24 UTC, Prarit Bhargava
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0791 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 6 2007-11-14 18:25:55 UTC

Description Xin-Yun Liu (Wolke Liu) 2007-02-02 07:45:47 UTC
we set udma mode for 40pin in original code. It's dangerous. 
Now we add code to choose correct dma mode for PATA.
Patch ready and tested.

sb600_ide_udma_mode.patch is the root cause for this bug.

sb600_ide_one_channel.patch is to clean up the code for SB600 IDE controller

Version-Release number of selected component (if applicable):
kernel-2.6.9-42

How reproducible:
Always

Use IDE harddisk with 40-pin cable. Install OS onto it or just use it as data 
disk.

Actual Results:
1. data on IDE disk will be lost when connected with 40-pin cable


Expected Results:
when connected to 40-pin cable, it should not use udma mode

Additional info:

Comment 1 Xin-Yun Liu (Wolke Liu) 2007-02-02 07:48:00 UTC
Created attachment 147194 [details]
SB 600 IDE controller only has one channel

Comment 2 Alan Cox 2007-02-02 09:07:53 UTC
I am unable to duplicate case #1. The disk subsystem reports some errors caused
by CRC failure and then changes down to UDMA33. This in turn only occurs if the
drive side detect is also wrong. Also does not appear to correct handle
suspend/resume which is probably not a concern for 4.x but may be for 5


Comment 3 Xin-Yun Liu (Wolke Liu) 2007-02-02 09:27:18 UTC
Created attachment 147204 [details]
fix udma mode issue

These two patches have been accepted by kernel.org

Comment 5 RHEL Product and Program Management 2007-05-09 08:00:00 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 6 Prarit Bhargava 2007-06-21 18:33:15 UTC
*** Bug 234245 has been marked as a duplicate of this bug. ***

Comment 11 Prarit Bhargava 2007-07-05 15:24:45 UTC
Created attachment 158604 [details]
RHEL4.6: fix for this issue

Comment 12 Prarit Bhargava 2007-07-11 17:34:45 UTC
*** Bug 228400 has been marked as a duplicate of this bug. ***

Comment 13 Jason Baron 2007-07-27 16:02:41 UTC
committed in stream U6 build 55.24. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/


Comment 15 John Poelstra 2007-08-29 04:25:34 UTC
A fix for this issue should have been included in the packages contained in the
RHEL4.6 Beta released on RHN (also available at partners.redhat.com).  

Requested action: Please verify that your issue is fixed to ensure that it is
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.

Comment 16 John Poelstra 2007-09-05 22:23:34 UTC
A fix for this issue should have been included in the packages contained in 
the RHEL4.6-Snapshot1 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed to ensure that it is 
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed, 
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent 
symptoms of the problem you are having and change the status of the bug to 
FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test 
results to Issue Tracker.  If you need assistance accessing 
ftp://partners.redhat.com, please contact your Partner Manager.

Comment 18 errata-xmlrpc 2007-11-15 16:19:20 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html



Note You need to log in before you can comment on or make changes to this bug.