Bug 22696 - [RFE] reenable playing of GSM files
Summary: [RFE] reenable playing of GSM files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: sox   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 22726
TreeView+ depends on / blocked
 
Reported: 2000-12-21 21:56 UTC by Enrico Scholz
Modified: 2014-03-17 02:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-22 09:12:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2000-12-21 21:56:44 UTC
although sox is able to play gsm files you have added a patch disabling
this capability. I removed the patch, updated to a newer gsm-version
(1.0.10) and all things are working fine.

Perhaps you should consider to update gsm in the powertools and remove the
patch too...

Comment 1 Bill Nottingham 2000-12-22 05:27:05 UTC
It was taken out because building it relied on the GSM
package, which wasn't in the base distro.

Comment 2 Enrico Scholz 2000-12-22 09:04:27 UTC
I have build sox without the sox-12.17-nogsm.patch and without '--without-gsm'.
I could not see any problems (tried without gsm, with gsm-1.0-8 and selfbuild
gsm-1.0.10)...

Comment 3 Enrico Scholz 2000-12-22 09:12:16 UTC
Ooops, wrong xterm... 
gsm-1.0-8 provided by powertools corrupts the build.

Perhaps update to 1.0.10 should be considered.

Comment 4 Bill Nottingham 2001-01-02 17:03:18 UTC
fixed in sox-12.17.1-1, will be in next rawhide release.


Note You need to log in before you can comment on or make changes to this bug.