Bug 226978 - Unable to use 1920x1200 resolution with intel i945 onboard graphics and i810 xorg driver
Unable to use 1920x1200 resolution with intel i945 onboard graphics and i810 ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-02 08:28 EST by Dave Russell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 18:31:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf with as many of the options as possible enabled for 1920x1200 resolution (1.11 KB, text/plain)
2007-02-02 08:28 EST, Dave Russell
no flags Details
xorg log file (89.02 KB, text/plain)
2007-02-02 08:31 EST, Dave Russell
no flags Details

  None (edit)
Description Dave Russell 2007-02-02 08:28:33 EST
Description of problem:

system-config-display correctly selects 1920x1200 both as the correct resolution
and that I have a 1920x1200 display.

However the maximum resolution I have been able to get it to display is 1600x1200.

The highest resolution I am able to get it to display is 1600x1200. 

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-1.6.5-10.fc6
xorg-x11-server-Xorg-1.1.1-54.fc7
915resolution-0.5.2-4.fc6

How reproducible:

Every time.

Steps to Reproduce:

1. Set 915resolution in rc.local to patch 3c, 4d and 5c from 1920x1440 to 1920x1200
2. Configure xorg using system-config-display
3. Start X, and see the maximum resolution displayed is 1600x1200 :o/
  
Actual results:

1600x1200 is the maximum resolution displayed. Regardless of what is set in the
xorg.conf file

Interestingly if I patch the 1600x1200 resolutions to 1920x1200 then X displays
at the next lowest resolution reported by 915resolution, 1280x1024.

Expected results:

1920x1200 Resolution

Additional info:

[root@luggage ~]# 915resolution -l
Intel 800/900 Series VBIOS Hack : version 0.5.2

Chipset: 945G
BIOS: TYPE 1
Mode Table Offset: $C0000 + $269
Mode Table Entries: 27

Mode 30 : 640x480, 8 bits/pixel
Mode 32 : 800x600, 8 bits/pixel
Mode 34 : 1024x768, 8 bits/pixel
Mode 38 : 1280x1024, 8 bits/pixel
Mode 3a : 1600x1200, 8 bits/pixel
Mode 3c : 1920x1200, 8 bits/pixel
Mode 41 : 640x480, 16 bits/pixel
Mode 43 : 800x600, 16 bits/pixel
Mode 45 : 1024x768, 16 bits/pixel
Mode 49 : 1280x1024, 16 bits/pixel
Mode 4b : 1600x1200, 16 bits/pixel
Mode 4d : 1920x1200, 16 bits/pixel
Mode 50 : 640x480, 32 bits/pixel
Mode 52 : 800x600, 32 bits/pixel
Mode 54 : 1024x768, 32 bits/pixel
Mode 58 : 1280x1024, 32 bits/pixel
Mode 5a : 1600x1200, 32 bits/pixel
Mode 5c : 1920x1200, 32 bits/pixel
Comment 1 Dave Russell 2007-02-02 08:28:33 EST
Created attachment 147221 [details]
xorg.conf with as many of the options as possible enabled for 1920x1200 resolution
Comment 2 Dave Russell 2007-02-02 08:31:47 EST
Created attachment 147222 [details]
xorg log file
Comment 3 Adam Jackson 2007-02-05 15:28:47 EST
Standard disclaimer: 915resolution isn't supported, etc.

I can't figure out offhand why it's claiming "no mode of this name", since there
pretty clearly is one of that name even in the VBE dump.  There's only like four
places where that failure code can come from within the server, and I don't see
immediately why you'd be hitting any of them.  Checking though.
Comment 4 Dave Russell 2007-02-05 15:42:04 EST
OK, thanks for looking at this, several questions immediatly spring to mind, one
is why it goes to the next lowest resolution if I patch the 1600x1200...?

Secondly, how far are we away from using the "modesetting" branch of xorg? As I
understand it that will remove the need to use 915resolution, is that correct?

Looking forward to hearing more, I'm away from the machine, but any tests you
want I can run at the end of the week.
Comment 5 Adam Jackson 2007-02-12 14:19:41 EST
We're looking at making the modesetting driver the default for i915 and newer
for FC7, which would remove the need for 915resolution, yes.
Comment 6 Dave Russell 2007-02-19 00:36:39 EST
I just found out that we already package the new driver, and sure enough, if I
change the driver in xorg.conf from i810 to intel... it works, 1920x1200 with no
915resolution needed.

ajax, if you can confirm that this all looks ok, or is at least expected
behaviour then I'm happy for either of us to close this.
Comment 7 David Juran 2007-02-21 10:34:24 EST
Dave, which kernel are you using? I found that with 2.6.19-1.2911.fc6 (and the
i810 driver) if I boot the xen kernel I only get 1600x1200 while with the
"vanilla" kernel I get the full 1920x1200. Is this the same issue?
Comment 8 David Juran 2007-02-22 10:03:15 EST
No, my problem seems to be a different one from Dave Russel's. I've buggered off
and created Bug 229652 about my issue.
Comment 9 Adam Jackson 2007-04-10 18:31:02 EDT
i810 video support in rawhide (as of tomorrow) will use the intel driver by
default for all 945 and 945 chips, as well as 915GM laptops.  Marking as
resolved in rawhide, but please reopen if this comes back or if you have problem
with F7.

Note You need to log in before you can comment on or make changes to this bug.