Bug 22701 - Disk Druid fails -- installer dies
Summary: Disk Druid fails -- installer dies
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard: Florence Beta-3
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-21 23:07 UTC by Chris Runge
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-16 18:01:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Runge 2000-12-21 23:07:28 UTC
Florence beta 1

This is on a Dell OptiPlex GX1 with a ~13GB hard disk. ~GB is Windows ME
(FAT32 partition). Rest of drive had RHL 7 installed.

I get to the Disk Druid screen. I delete all of the old RHL 7 partitions,
leaving only the FAT32 partition. When I go to create a /boot partition of
16MB I get a message that it couldn't fit the boot partition and that it
will be unallocated. The /boot partition is in red in Disk Druid.
Interestingly, I can add other partitions like /, etc. and I don't get this
message. If I do this, but then delete /boot, then I get the error for /,
that it can't be allocated. If I continue the installer crashes
immediately, with no message other than it exited abnormally (no python
tracebacks or anything).

I don't know if this is related or not, but after the ide modules are
loaded, I get a strange set of messages on the screen:

invalid operand: 0000
CPU:     0
EIP: 0010:[<cc84eb27>]
EFLAGS: 00010206
.
.
.

I can get the full error text if necessary.

FWIW, I was able to install fine on another machine with a 20GB hard drive
and had Win98 on it. I deleted that partition and created new ones and
installed with no problems (in fact I'm writing this from that machine). I
wonder if the installer doesn't handle coexistent FAT32 partitions well or
something.

Marked as severe/high due to inability to even install....

Comment 1 Tim Waugh 2000-12-21 23:41:14 UTC
(I don't think the oops is related to that; when I chased it a few days ago it
was some bug in the xor module; mostly harmless.)

Comment 2 Michael Fulbright 2000-12-27 16:35:16 UTC
Please give the output of 'fdisk -l' for the original partitioning of the system
before trying installation, as well as a list of the partitions in that list
which you removed before trying to create the '/boot' partition.

Comment 3 Chris Runge 2001-01-04 02:08:20 UTC
same problem if I start with just a FAT32 partition before the install.

here is the output of fdisk from florence beta 1 during the install:

Command (m for help): p

Disk /tmp/hda: 16 heads, 63 sectors, 26377 cylinders
Units = cylinders of 1008 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/tmp/hda1   *         1     12495   6297448+   b  Win95 FAT32
Partition 1 does not end on cylinder boundary:
     phys=(783, 254, 63) should be (783, 15, 63)


For comparison purposes, here is the output of fdisk under RHL 7:


255 hears, 63 sectors, 1655 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/tmp/hda1   *         1       784   6297448+   b  Win95 FAT32


Nothing was changed between the time I got the output for each -- I assume
something is funny in the new kernel such that it is detecting the hard disk
differently

Comment 4 Glen Foster 2001-01-11 21:11:49 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 5 Chris Runge 2001-01-14 18:07:28 UTC
FWIW, still an issue in beta 2

Comment 6 Michael Fulbright 2001-01-16 18:00:48 UTC
I think I have this fixed, although I'm unclear about the original bug post. If
this was a GUI install then there is no way to proceed if '/' or '/boot' are
currently unallocated. In the TUI install there is no way to proceed in this
case w/o saying 'Yes' to a warning dialog, in which case its expected to fail
anyways.

Comment 7 Brock Organ 2001-01-16 21:02:54 UTC
you are correct about the 2.4 kernel vs 2.2 kernel reporting the same drive
geometry two different ways ... (that is another bug) ...

For this type of install, disk druid will not create a /boot partition above the
1024 cylinder limit.  To perform an install in the case that needs a /boot above
1024 cylinder, it is necessary to create the /boot partition in fdisk where
desired, and then assign a /boot mount point to the newly created partition ...
this DOES allow the install to procede, although a warning dialog is provided
since not all hardware that says it is able to boot above 1024 cyl actually does
... thanks for your report!



Note You need to log in before you can comment on or make changes to this bug.