Bug 227017 - xscreensaver-gl-extras should require xscreensaver-base
xscreensaver-gl-extras should require xscreensaver-base
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-02 11:48 EST by Nicola Soranzo
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.01-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-03 00:24:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicola Soranzo 2007-02-02 11:48:02 EST
Description of problem:
The StarWars screensaver included in the xscreensaver-gl-extras package needs
/usr/bin/xscreensaver-text to work correctly. This file is included in the
xscreensaver-base package, which presently is not a dependency for
xscreensaver-gl-extras.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install xscreensaver-gl-extras but not xscreensaver-base.
2. Select StarWars as preferred screensaver.
3. Start the screensaver
  
Actual results:
"sh: xscreensaver-text: command not found" is displayed on the screen.

Expected results:


Additional info:
Comment 1 Mamoru TASAKA 2007-02-02 11:52:43 EST
Well, I surely know this and perhaps jwz (upstream) knows
this.
I will mail to jwz to discuss this issue, plus some
idea.

By the way why does this bug have fedora-review flag?
Comment 2 Mamoru TASAKA 2007-02-03 00:24:51 EST
Okay, jwz and me agreed.
Requires is added, plus metapackage xscreensaver is created
for convenience.

Should be fixed in 5.01-6.fc[76]. Thank you for your report.

Note You need to log in before you can comment on or make changes to this bug.