Bug 227097 - missing symbols in pam_krb5
missing symbols in pam_krb5
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pam_krb5 (Show other bugs)
4.4
All Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-02 12:50 EST by Paolo Penzo
Modified: 2010-10-22 08:50 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHEA-2007-0790
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:12:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pam_krb5 libpam patch (336 bytes, patch)
2007-02-02 12:50 EST, Paolo Penzo
no flags Details | Diff
Simple test for modules with undefined symbols which don't link with libraries which provide them. (1.72 KB, application/octet-stream)
2007-07-09 09:55 EDT, Nalin Dahyabhai
no flags Details

  None (edit)
Description Paolo Penzo 2007-02-02 12:50:31 EST
pam_krb5.so has missing symbols due to lack of linkage to libpam (see bug #183363).
Comment 1 Paolo Penzo 2007-02-02 12:50:31 EST
Created attachment 147244 [details]
pam_krb5 libpam patch
Comment 2 RHEL Product and Program Management 2007-05-09 03:58:37 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Brian Brock 2007-07-09 09:44:42 EDT
A test plan / code block would be very useful for QA.
Comment 8 Nalin Dahyabhai 2007-07-09 09:55:36 EDT
Created attachment 158770 [details]
Simple test for modules with undefined symbols which don't link with libraries which provide them.

The bug is pretty straightforward: if you use dlopen() to open the library, and
you're not already linked to libpam, it fails because there are symbols in
libpam on which the module depends.  If running this script against the module
like so:
  ./dlopen.sh ./pam_krb5.so
fails while running it like so:
  ./dlopen.sh ./pam_krb5.so -lpam
succeeds, then you have the behavior described as in the report.  The desired
behavior is for the script to succeed in both cases.
Comment 15 errata-xmlrpc 2007-11-15 11:12:30 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0790.html

Note You need to log in before you can comment on or make changes to this bug.