Bug 227166 - ISE on login + Can't see rows On users page...
ISE on login + Can't see rows On users page...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn415
All Linux
medium Severity medium
: ---
: ---
Assigned To: Partha Aji
Red Hat Satellite QA List
https://rhn.webqa.redhat.com/rhn/user...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-02 16:09 EST by Partha Aji
Modified: 2008-04-21 12:10 EDT (History)
1 user (show)

See Also:
Fixed In Version: 500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 12:10:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Partha Aji 2007-02-02 16:09:27 EST
Description of problem:
Go to https://rhn.webqa.redhat.com/rhn/users/ActiveList.do using the following
login ->  rspell/redhat
Notice that the line between mduskis and rspell is blank... 
The following query on webqa shows the logins that won't similaruly get
displayed on the user's list
"
select wc.login, wc.password, wc.org_id from web_contact wc where not exists
(select 1 from rhnuserinfo RUI where RUI.user_id = wc.id) order by wc.org_id;
"

Another problem related to users in the above list is the ISE that shows up when
they try to login...

Version-Release number of selected component (if applicable): 416 Hosted


How reproducible:


Steps to Reproduce:
1. Run the following query in yasql
select wc.login, wc.password, wc.org_id from web_contact wc where not exists
(select 1 from rhnuserinfo RUI where RUI.user_id = wc.id) order by wc.org_id;
2. Using the login and password info try to login to webdev .. Notice the ISE

3. Next Login using rspell/redhat and click on 'Users' link.. Notice the blank
line between mduskis and rspell.. 

Additional info:
Basically we have a the sql query described in step 1 should result in Zero
rows.. For every user created in web_contact there must be a row in rhnUserInfo...
Comment 1 Corey Welton 2007-02-05 11:24:37 EST
QA Verified:
* Aforementioned query no longer returns any results.
* Previously affected user accounts can now login
* Accounts no longer appear as blank rows in the users list


Note You need to log in before you can comment on or make changes to this bug.