Bug 227249 - RHEL4.5 NFSv2 intermittently fails connectathon basic test 7 when run against solaris NFS server
RHEL4.5 NFSv2 intermittently fails connectathon basic test 7 when run against...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Layton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-03 18:17 EST by Jeff Layton
Modified: 2007-11-16 20:14 EST (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:19:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add some missing inode revals (1.84 KB, patch)
2007-02-03 18:22 EST, Jeff Layton
no flags Details | Diff
respun patch that just includes the bit for nfs_proc_link (2.67 KB, patch)
2007-02-16 16:08 EST, Jeff Layton
no flags Details | Diff

  None (edit)
Description Jeff Layton 2007-02-03 18:17:55 EST
Connectathon basic test 7 (which tests renaming and hard linking) intermittently
fails when run against a Solaris 10 NFS server.
Comment 1 Jeff Layton 2007-02-03 18:22:16 EST
Created attachment 147289 [details]
patch to add some missing inode revals

This patch seems to correct the problem. Without it, the test was pretty
regularly failing to notice that the i_nlink count had been incremented after
the link call. With this patch though, it seems to work. Looks like it may also
prevent some other v2 problems as well...
Comment 2 Jeff Layton 2007-02-16 10:57:59 EST
A very easy reproducer for this. Mount a NFSv2 filesystem:

# cd mounted_filesystem
# mkdir d1 d2
# touch d1/foo; ln d1/foo d2/bar; stat d1/foo
  File: `d1/foo'
  Size: 0               Blocks: 8          IO Block: 4096   regular empty file
Device: 11h/17d Inode: 1048679     Links: 1
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2007-02-16 10:56:06.000000000 -0500
Modify: 2007-02-16 10:56:06.000000000 -0500
Change: 2007-02-16 10:56:06.000000000 -0500

Links should be 2 here. If you wait a few seconds and stat it again, it is.
Comment 4 Jeff Layton 2007-02-16 16:08:44 EST
Created attachment 148245 [details]
respun patch that just includes the bit for nfs_proc_link

This patch is a smaller patch that just corrects the problem in the reproducer
without the other bits that we may not need.
Comment 6 RHEL Product and Program Management 2007-03-08 10:24:08 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 RHEL Product and Program Management 2007-04-18 18:32:54 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 10 Jason Baron 2007-05-23 14:34:39 EDT
committed in stream U6 build 55.4. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 13 errata-xmlrpc 2007-11-15 11:19:29 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html

Note You need to log in before you can comment on or make changes to this bug.