Bug 227250 - anaconda not setting hostname properly on manual hostname override due to /etc/sysconfig/network error.
anaconda not setting hostname properly on manual hostname override due to /et...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
: 231012 231650 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-03 18:21 EST by Jeremy Rosengren
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-23 10:57:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Rosengren 2007-02-03 18:21:06 EST
Description of problem:

Fresh install of F7 test 1.  During installation, I selected DHCP for network
configuration, but chose a manual hostname.  After final reboot, I noticed that
the hostname specified at a command prompt was "localhost".  I found that
/etc/sysconfig/network looked a little goofy:

NETWORKING=yes
yesHOSTNAME=testhost

I removed the extra "yes" and a # service network restart fixed the problem.

Version-Release number of selected component (if applicable):

dhclient-3.0.5-8.fc7

How reproducible:

Only tried once

Steps to Reproduce:
1. Install F7 test 1
2. Select DHCP under network configuration (default options for everything
except hostname)
3. Specify hostname override on the network configuration installation page
4. After final reboot after installation, hostname display at terminal prompt
will be localhost
  
Actual results:

[jeremy@localhost ~]$

Expected results:

[jeremy@testhost ~]$

Additional info:
Comment 1 Jeremy Rosengren 2007-02-03 18:22:31 EST
After filing this bug, it occurred to me that it might be a problem with
anaconda instead of dhclient.
Comment 2 Jonathan Berry 2007-02-07 22:13:22 EST
I got this too.  I installed F7T1 x86_64, so this is probably not arch specific.
Comment 3 Joachim Frieben 2007-02-17 08:27:37 EST
Same for "anaconda-11.2.0.24-1" and "dhclient-3.0.5-20.fc7" as of
2007-02-17.
Comment 4 Orion Poplawski 2007-02-22 16:44:07 EST
Installed with 20070222 rawhide and the following kickstart opts:

network --bootproto=dhcp
authconfig --enableshadow --enablenis --nisdomain=yp.colorado-research.com

And ended up with:

NETWORKING=yes
yesHOSTNAME=denali

note no DOMAINNAME.
Comment 5 Chris Lumens 2007-02-23 10:57:06 EST
Orion - the lack of DOMAINNAME is a different bug.  It looks like the authconfig
parameters are getting dropped, most likely due to something I broke in the last
pykickstart reorganization.  No need to open a new bug, though, I'll take care
of that right now.

The original bug report here has been fixed and will be in the next build of
anaconda.
Comment 6 Gerry Tool 2007-03-02 09:09:02 EST
This problem still exists in F7 Test 2, which acts slightly different from F7
Test 1.  (I now get a correct prompt in Test 1, but not in Test 2, even though
the naming files are of the same form.)

When in F7T2, the terminal prompt lists my computer as localhost, even though I
gave it a name during install.
[root@localhost ~]#

When in F7T1, it lists my computer as F7T1, the name I gave it when installing
from DVD.
[root@f7t1] ~]#

The /etc/hosts files have the same form:
[root@localhost ~]# diff /etc/hosts /mnt/f7t1/etc/hosts
3c3
< 127.0.0.1     f7t2.thetoolshed.us     f7t2    localhost.localdomain   localhost
---
> 127.0.0.1     f7t1.thetoolshed.us     f7t1    localhost.localdomain    localhost

This naming persists, even though I set hostname with the hostname command.

The next time I boot to f7t2, the hostname is back to "localhost"
[root@localhost ~]# hostname
localhost
[root@localhost ~]# hostname f7t2.thetoolshed.us
[root@localhost ~]# hostname
f7t2.thetoolshed.us

In f7t1:
[root@f7t1 ~]# hostname
f7t1.thetoolshed.us

Here are the /etc/sysconfig/network file contents:
[root@localhost ~]# cat /etc/sysconfig/network
NETWORKING=yes
yesHOSTNAME=f7t2.thetoolshed.us
[root@localhost ~]# cat /mnt/f7t1/etc/sysconfig/network
HOSTNAME=f7t1.thetoolshed.us
NETWORKING=yes
yesHOSTNAME=f7t1.thetoolshed.us
Comment 7 Chris Lumens 2007-03-02 09:54:04 EST
The fix for this is in anaconda-11.2.0.27, while the version in test 2 is
11.2.0.26.  That unfortunately means this bug fix is not in the test 2 tree
which would explain why you are still seeing it.
Comment 8 David Cantrell 2007-03-06 13:57:01 EST
*** Bug 231012 has been marked as a duplicate of this bug. ***
Comment 9 David Cantrell 2007-03-09 15:07:49 EST
*** Bug 231650 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.