Bug 227284 - DistRegex option in config file doesn't match el as dist tag
DistRegex option in config file doesn't match el as dist tag
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: rpmlint (Show other bugs)
el4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-04 14:03 EST by Reza Mohammadi
Modified: 2007-04-18 13:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: rpmlint-0-79-1-el4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-04 03:33:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reza Mohammadi 2007-02-04 14:03:26 EST
Description of problem:
not suitable DistRegex setted in /usr/share/rpmlint/config

Version-Release number of selected component (if applicable):
rpmlint-0.78-2.el5

line 8 of /usr/share/rpmlint/config :
setOption("DistRegex", '\.(fc|rhe?l)\d+(?=\.|$)'

This regex doesn't match el as dist tag.
Comment 1 Tim Powers 2007-02-12 09:23:44 EST
rpmlint isn't included in the RHEL 5 beta. Please file a bug report with the distribution or upstream that 
you downloaded the package from so that they can the correct dist tag.

I'm changing the resoluton of this to CANTFIX because we don't ship that package.
Comment 2 Roozbeh Pournader 2007-02-12 11:02:16 EST
Re-opening bug. This should have been filed against Fedora Extras, not RHEL. See
also: http://fedoraproject.org/wiki/Packaging/DistTag
Comment 3 Ville Skyttä 2007-02-12 11:25:13 EST
Coincidentally (I didn't see this bug before now), this should have been fixed
in 0.79-1.fc*, shipped 1½ weeks ago in the Fedora Extras package.

But this is about the EPEL version (not Fedora Extras) so getting the fix to the
EPEL repo is a for whoever maintains rpmlint in EPEL to decide.  Reassigning to
Dennis who apparently created the rpmlint EL-5 branch.

Dennis, FYI: Bugzilla doesn't have a el5 version for EPEL at all, and rpmlint is
missing from the el4 version too.  Please add rpmlint to owners.epel.list.
Comment 4 Ville Skyttä 2007-02-25 11:41:46 EST
Reassigning to current EPEL rpmlint maintainer.
Comment 5 Thorsten Leemhuis 2007-03-04 03:33:09 EST
build rpmlint-0_79-1_el4 for EL4

Note You need to log in before you can comment on or make changes to this bug.