Bug 227364 - built-in testsuite does not work on 64bit arches
built-in testsuite does not work on 64bit arches
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: postgresql (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
Kevin Baker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-05 11:46 EST by Radek Bíba
Modified: 2014-12-01 18:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:17:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2007-02-05 11:46:19 EST
Description of problem:
The built-in testsuite does not work on s390x and x86_64. First of all,
/usr/share/doc/postgresql-7.4.13/README.rpm-dist suggests cd'ing to
/usr/lib/pgsql/test/regress, but postgresql-test uses /usr/lib64/... on
64bit arches. Secondly, if you go to /usr/lib64/pgsql/test/regress, pg_regress
fails anyway:

...
============== installing PL/pgSQL                    ==============
createlang: language installation failed: ERROR:  could not access file
"/usr/lib/pgsql/plpgsql": No such file or directory pg_regress: createlang
failed
...

Version-Release number of selected component (if applicable):
postgresql-7.4.16-1.RHEL4.1

How reproducible:
Always

Steps to Reproduce:
1. see above
  
Actual results:
see above

Expected results:
success

Additional info:
Just out of curiosity, I tried to hack pg_regress to use
pkglibdir='/usr/lib64/pgsql' but many tests failed. Then I tried to revert
this hack and simply create a symlink from /usr/lib64/pgsql to /usr/lib/psql
and everything was great. Not sure if this is correct, though.
Comment 1 Tom Lane 2007-02-05 12:16:48 EST
Yeah, this works in PG 8.0 and up but nobody ever bothered to fix it in 7.4.
I suppose if we're going to ship the postgresql-test RPM then we ought to make
some effort to make it work out-of-the-box ...
Comment 2 RHEL Product and Program Management 2008-02-01 14:10:00 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 Jiri Pallich 2012-06-20 09:17:50 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.