Bug 227400 - rubygems always exits with LoadError
rubygems always exits with LoadError
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rubygems (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lutterkort
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-05 15:04 EST by Dean Mander
Modified: 2013-04-30 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.9.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-27 20:31:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
one line patch (485 bytes, patch)
2007-02-05 21:47 EST, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Dean Mander 2007-02-05 15:04:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.9) Gecko/20061219 Fedora/1.5.0.9-1.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
I installed:
$ yum install ruby-docs ruby-sqlite ruby-devel rubygems ruby-activerecord ruby-mysql

then I ran (for installing the rails frameworks):
$ gem install rails

gives error:

/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require': no such file to load -- sources (LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:6
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:12
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:111:in `manage_gems'
        from /usr/bin/gem:10


in fact, the error is generic: running just "gem" gives the same error.



Version-Release number of selected component (if applicable):
rubygems-0.9.1-1.fc6

How reproducible:
Always


Steps to Reproduce:
1. run the gems command
2.
3.

Actual Results:


Expected Results:


Additional info:
I have installed the same software and versions of gem on a i386 system; here no problems...
Comment 1 Akira TAGOH 2007-02-05 21:45:56 EST
It looks like a multilib issue in rubygems. rubygems shouldn't refers
CONFIG['libdir'] to build the default path of gems for 64bit arch since it's a
noarch package.
Comment 2 Akira TAGOH 2007-02-05 21:47:33 EST
Created attachment 147431 [details]
one line patch
Comment 3 Dean Mander 2007-02-06 13:56:19 EST
The patch solves the problem.

Thanks for the superfast fix!

Comment 4 David Lutterkort 2007-02-27 20:30:22 EST
Fixed with update to 0.9.2

If anybody's interested, I used a slight variation of Akira's patch:

--- rubygems-0.9.1/lib/rubygems.rb.orig 2007-02-12 15:36:46.000000000 -0800
+++ rubygems-0.9.1/lib/rubygems.rb      2007-02-12 15:43:35.000000000 -0800
@@ -457,7 +457,9 @@
       if defined? RUBY_FRAMEWORK_VERSION
         return File.join(File.dirname(Config::CONFIG["sitedir"]), "Gems")
       else
-        File.join(Config::CONFIG['libdir'], 'ruby', 'gems',
Config::CONFIG['ruby_version'])
+        gemdir =
File::expand_path(File::join(Config::CONFIG["sitedir"],"..","gems"))
+
+        File.join(gemdir, Config::CONFIG['ruby_version'])
       end
     end

Note You need to log in before you can comment on or make changes to this bug.