Bug 227429 - fix install script in spec file
fix install script in spec file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-05 16:47 EST by sean
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-26 10:42:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2007-02-05 16:47:26 EST
Description of problem:

using the spec file from  sox-12.18.1-1.src.rpm, to try sox-13.0.0rc1 I noticed
the script after %makeinstall. Didn't make much sense to me, so I asked the
upstream maintainer about it.


Comments below:

sean wrote:
> I 'm building 12.99.9 as an rpm using the spec file from
> sox-12.18.1-1.src.rpm, the current Fedora Core sox release.
> The spec file has these "fixes" just after make install:
>
>
> echo "#!/bin/sh" > $RPM_BUILD_ROOT%{_bindir}/soxplay
> echo "" >> $RPM_BUILD_ROOT%{_bindir}/soxplay
> echo '%{_bindir}/sox "$1" -t .au - > /dev/audio' >>
> $RPM_BUILD_ROOT%{_bindir}/soxplay
> chmod 755 $RPM_BUILD_ROOT%{_bindir}/soxplay
>
No, we do not need this part.  Fedora/Redhat has always included this
script for reasons I've never known.  The standard "play" command that
comes with sox is infinitely better to use.

> # fix symlinks
> ln -snf play $RPM_BUILD_ROOT%{_bindir}/rec
> rm -f $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
> ln -snf sox.1 $RPM_BUILD_ROOT%{_mandir}/man1/soxmix.1

> Are these just Fedora'isms, or something to consider for 13.0?
>

The first part, they appear to be correcting some symlinks that "make install"
does.  I've no idea what could be wrong with them in Fedora builds but if its
truely an issue then it needs to be updated as follows because the "play" script
was been absorbed into the sox binary.  I'd be interested in if we could do
something to our Makefiles to not have to do this "fix".

# fix symlinks
ln -snf sox $RPM_BUILD_ROOT%{_bindir}/play
ln -snf sox $RPM_BUILD_ROOT%{_bindir}/rec

The next part looks like they do not wish to distribute the man page for "rec"
which used to be a symlink to play.1.  So they should either be deleting both
rec.1 and play.1 symlink that "make install" creates or "fix"ing them similar to
above.

rm -f $RPM_BUILD_ROOT%{_mandir}/man1/play.1
rm -f $RPM_BUILD_ROOT%{_mandir}/man1/rec.1

And last, the soxmix program has been rolled into sox binary as a command line
option.  The following line should be removed.

#ln -snf sox.1 $RPM_BUILD_ROOT%{_mandir}/man1/soxmix.1

I guess we should ask about and/or point out the issues with the .spec maintainer.

Chris

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Bagwell 2007-02-05 16:56:27 EST
chris@cnpbagwell.com
Comment 2 Thomas Woerner 2007-02-26 10:42:47 EST
Fixed in rawhide in rpm sox-13.0.0-1 or newer.
Comment 3 Bill Nottingham 2007-03-02 12:30:31 EST
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.

Note You need to log in before you can comment on or make changes to this bug.