Bug 22745 - wu-ftpd hammers argv[0] affecting syslog name
wu-ftpd hammers argv[0] affecting syslog name
Status: CLOSED DUPLICATE of bug 17807
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Need Real Name
Depends On:
  Show dependency treegraph
Reported: 2000-12-22 10:21 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-12 17:08:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-22 10:21:46 EST
wu-ftpd as shipped hammers argv[0] which affects the name syslog uses to
log.  for example:

Dec 20 10:40:28 twinlark ftpd: w221.z208176006.sjc-ca.dsl.cnc.net:
[11234]: lost connection to w221.z208176006.sjc-ca.dsl.cnc.net

everything after "twinlark" and before "[11234]", including the spaces is
the argv[0] value... it's supposed to be the daemon name, such as "ftpd".

the patch to fix this is trivial.  it's included below.


--- wu-ftpd-2.6.0/src/ftpd.c.noproctitle        Fri Dec 22 07:14:25 2000
+++ wu-ftpd-2.6.0/src/ftpd.c    Fri Dec 22 07:14:56 2000
@@ -6578,7 +6578,7 @@
 #define SPACELEFT(buf, ptr)  (sizeof buf - ((ptr) - buf))
 #ifndef SPT_TYPE
+#define SPT_TYPE       SPT_NONE
Comment 1 WU-FTPD Development Group 2001-03-12 17:08:33 EST
PAM bug.

Duplicate of 17807.

Close this.  Except for using SPT_NONE, there is nothing WU-FTPD can do to work 
arround PAM's mistake.
Comment 2 Bernhard Rosenkraenzer 2001-03-16 07:18:04 EST

*** This bug has been marked as a duplicate of 17807 ***

Note You need to log in before you can comment on or make changes to this bug.