Bug 22746 - X command does not work properly
X command does not work properly
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-22 10:59 EST by Sebastiaan
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 08:45:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastiaan 2000-12-22 10:59:15 EST
When startx command is used the default windowmanager loads.
When the X command is used to start X windows no windowmanager loads.
Root can use startx, normal users must use the X command which leaves X-
windows unavailable for normal users.
Comment 1 Bill Nottingham 2000-12-22 11:51:26 EST
This is behaving as normal. X *just* starts the X server.

Why do you say that normal users can't use startx - that's not the case.
Comment 2 Sebastiaan 2000-12-22 13:10:31 EST
Because this is the error i get when I try to run startx as a normal user:

Fatal server error:
xf86OpenConsole: Server must be running with root permissions
You should be using Xwrapper to start the server or xdm.
We strongly advise against making the server SUID root!
Comment 3 Bill Nottingham 2000-12-22 16:46:59 EST
It looks like your symlink in /usr/X11R6/bin is wrong. What does
/usr/X11R6/bin/X point to?
Comment 4 Sebastiaan 2000-12-23 08:24:39 EST
[/usr/x11r6/bin/]
lrwxrwxrwx    1 root     root            8 Dec 22 16:15 X -> Xwrapper
-rwxr-xr-x    1 root     root      3147364 Dec 22 15:37 XF86_SVGA
-rwx--x--x    1 root     root      1538632 Aug 30 21:55 XFree86
-rwxr-xr-x    1 root     root         2001 Aug 30 21:54 startx

[/etc/X11/]
lrwxrwxrwx    1 root     root           29 Dec 22 15:38 X -
> ../../usr/X11R6/bin/XF86_SVGA
-rw-r--r--    1 root     root        14031 Dec 22 15:39 XF86Config
Comment 5 Bill Nottingham 2000-12-23 23:39:37 EST
Odd. Is /usr/X11R6/bin/Xwrapper setuid root, and do you have an
/etc/pam.d/xserver file?
Comment 6 Sebastiaan 2000-12-24 08:37:35 EST
I did a standard GNOME Workstation install.
I don't know what setuid is, here is some more information:

[/etc/pam.d/xserver]
#%PAM-1.0
auth       sufficient   /lib/security/pam_rootok.so
auth       required     /lib/security/pam_console.so
account    required     /lib/security/pam_permit.so

[/usr/X11R6/bin/]
-rws--x--x    1 root     root         6024 Aug 30 21:55 Xwrapper
Comment 7 Mike A. Harris 2001-01-03 02:25:48 EST
Please cut and paste the exact output of the "startx" command when
ran as a normal user.
Comment 8 Sebastiaan 2001-01-03 08:45:12 EST
Fatal server error:
xf86OpenConsole: Server must be running with root permissions
You should be using Xwrapper to start the server or xdm.
We strongly advise against making the server SUID root!
Comment 9 Mike A. Harris 2001-03-23 01:14:44 EST
It seems as though you have improper permissions on some files in your system.
I cannot reproduce this locally.  Make sure the permissions on your device
files, are correct, and also use "rpm -Va" to verify the permissions, etc on
the rest of your system.  In particular make sure the setuid bit is set on
Xwrapper like is suggested above.

Note You need to log in before you can comment on or make changes to this bug.