This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 227469 - Vim 'showmatch' broken with rxvt-unicode and termcap is to blame
Vim 'showmatch' broken with rxvt-unicode and termcap is to blame
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-06 01:40 EST by Penelope Fudd
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: vim-7.0.191-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 07:23:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Penelope Fudd 2007-02-06 01:40:50 EST
Description of problem:
If I edit a file with vim inside the rxvt-unicode terminal window, the
matching-bracket feature moves the visible cursor away from where it should be.

Version-Release number of selected component (if applicable):
termcap-5.5-1.20060701.1
rxvt-unicode-8.1-1.fc6
vim-enhanced-7.0.109-3

How reproducible:
Always

Steps to Reproduce:
1. vim some-file-with-brackets (perl program?)
2. move cursor over a bracket
3. watch the cursor highlight the matching bracket, but unhighlight the bracket
you're on
  
Actual results:
The cursor appears in the wrong place.

Expected results:
The cursor should indicate where you're about to insert or delete.

Additional info:
Setting the terminal time to 'rxvt' fixes the problem.  Vim is using
/etc/termcap, the rxvt-unicode termcap entry needs help.
Comment 1 Miroslav Lichvar 2007-02-06 05:05:01 EST
Yes, the entry is missing Co, AF, AB capabilities that are required to enable
color mode in vim. Problem is that termcap entries are limited in length to 1023
bytes, this is one of the reasons why we are dropping termcap in next Fedora.

Linking vim from vim-enhanced package against libncurses instead of libtermcap
would be a good solution to this issue.
Comment 2 Karsten Hopp 2007-02-06 07:23:04 EST
vim-7.0.191-1.fc6 will be built with ncurses, but it'll take some time to get 
to the mirrors

Note You need to log in before you can comment on or make changes to this bug.