Bug 227651 - Missing dependencies
Missing dependencies
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: devhelp (Show other bugs)
6
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-07 06:59 EST by Blayne Maring
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: Fedora 7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 01:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Blayne Maring 2007-02-07 06:59:47 EST
On Software Update, getting the following error:
Missing Dependency: gecko-libs = 1.8.0.7 is needed by package devhelp
Additional info:
Comment 1 Blayne Maring 2007-02-09 08:47:13 EST
The RPM causing the missing dependencies is Firefox
Comment 2 Matthew Barnes 2007-02-09 10:59:35 EST
Make sure you have an up-to-date devhelp package.
The latest, devhelp-0.12.6-9.fc6, requires gecko-libs 1.8.0.9.
Comment 3 Mike Hammill 2007-02-12 07:45:04 EST
I am getting the same error only with hardware == powerpc (i.e., ppc32).  I have
only been doing "yum update" since I got the machine running with FC6.
Comment 4 Carl-Johan Kjellander 2007-02-15 09:51:52 EST
Did you guys do an update with pup/pirut that crashed X some time ago?

In this case you might have multiple programs installed according to
the rpm database. Do this:

rpm -qa | sort >~/all.rpms
less ~/all.rpms

Do you have any duplicates, i.e. packages listed twice with different
versions? You might not actually have them, but according to the
database you do.

Easiest way to work around this, is to update all the packages again
with force! If you haven't cleaned out the old updates with
'yum clean' than there is an easy way.

cd /var/cache/yum/updates/packages/
rpm -Uvh --force *.rpm

If it complains, try to figure out if you have more than one
rpm, of for instance kernel, and remove the ones with the lowest
version. And just try deleting rpms that give you trouble.
Once it starts working, it will reinstall all updates you've done
once again, and properly remove the old stale packages in the
database.

After that, a 'yum -y update' will get your system up to speed again.
Comment 5 Matthew Barnes 2007-10-05 01:05:19 EDT
This particular problem was fixed some time ago, but these dependency errors
crop up from time to time whenever we see a new Firefox version.

Closing as CURRENTRELEASE (Fedora 7).

Note You need to log in before you can comment on or make changes to this bug.