Bug 227712 - [RHEL5] evolution hangs at random time while trying to switch messages or mailboxes
[RHEL5] evolution hangs at random time while trying to switch messages or mai...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Crha
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-07 13:25 EST by Subhendu Ghosh
Modified: 2008-06-17 12:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-17 12:27:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
evolution gdb thread all backtrace (9.62 KB, text/plain)
2007-02-08 23:44 EST, Subhendu Ghosh
no flags Details
Another backtrace from a different hang instance (8.67 KB, text/plain)
2007-02-09 18:58 EST, Subhendu Ghosh
no flags Details
trace with debug rpms (34.44 KB, text/plain)
2007-02-13 17:06 EST, Subhendu Ghosh
no flags Details

  None (edit)
Description Subhendu Ghosh 2007-02-07 13:25:00 EST
Description of problem:

At seemingly random times, Evolution hangs and is unresponsive in the message
list pane and message preview pane.  

Selecting a different message causes the message to by highlighted, but the
preview pane does not change and shows the old message's content.

Selecting different folders, causes the folder to be highlighted, but the folder
contents are not displayed in the message list pane.


Version-Release number of selected component (if applicable):
evolution-data-server-1.8.0-15.el5
evolution-webcal-2.7.1-6
evolution-2.8.0-33.el5
evolution-data-server-devel-1.8.0-15.el5
evolution-connector-2.8.0-3.fc6


How reproducible:

Happens at least a couple of times a day.  It does not matter if I am connecting
over VPN or in th office.
Steps to Reproduce:

1.
2.
3.
  
Actual results:

Evolution hangs - cannot see any messages, no new message are received.

Expected results:

normal operations.

Additional info:
Comment 1 Subhendu Ghosh 2007-02-07 13:25:00 EST
Created attachment 147580 [details]
Evolution is stuck - status bar does not update either.
Comment 2 Matthew Barnes 2007-02-07 14:59:07 EST
Thanks for the bug report.

Since this sounds like it's going to be difficult to reproduce reliably, could
you possibly attach a GDB backtrace of the Evolution process when it's hung?
Comment 3 Subhendu Ghosh 2007-02-08 10:08:00 EST
evolution --component=mail

(gdb) info stack
#0  0x0055f402 in __kernel_vsyscall ()
#1  0x001c45b3 in poll () from /lib/libc.so.6
#2  0x0537d353 in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0x0537d6c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#4  0x00857a23 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#5  0x0805d7ea in POA_GNOME_Evolution_DataServer_InterfaceCheck__fini ()
#6  0x00116dec in __libc_start_main () from /lib/libc.so.6
#7  0x0804f221 in ?? ()

/usr/bin/perl -T -w /usr/bin/spamd --socketpath
/home/sghosh/.evolution/cache/tmp/spamd-socket-path-P6cH5c --local
--max-children=1 --pidfile /home/sghosh/.evolution/cache/tmp/spamd-pid-file-bn4eD3

(gdb) info stack
#0  0x0098a402 in __kernel_vsyscall ()
#1  0x001c6f7d in ___newselect_nocancel () from /lib/libc.so.6
#2  0x007f3e84 in Perl_pp_sselect () from
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so
#3  0x007aa97f in Perl_runops_standard () from
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so
#4  0x007501ce in perl_run () from
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/CORE/libperl.so
#5  0x080491ee in main ()
Comment 4 Matthew Barnes 2007-02-08 12:07:46 EST
Thanks, but what I really need to see is:

(gdb) thread apply all backtrace
Comment 5 Subhendu Ghosh 2007-02-08 23:44:51 EST
Created attachment 147725 [details]
evolution gdb thread all backtrace
Comment 6 Subhendu Ghosh 2007-02-09 18:58:01 EST
Created attachment 147827 [details]
Another backtrace from a different hang instance
Comment 7 Matthew Barnes 2007-02-09 20:21:25 EST
Thanks.  Can I ask you to install some debuginfo packages so that debugging
information shows up in your backtraces?

   # yum install evolution-debuginfo
   # yum install evolution-data-server-debuginfo
   # yum install glib2-debuginfo
Comment 8 Subhendu Ghosh 2007-02-13 17:06:51 EST
Created attachment 148021 [details]
trace with debug rpms
Comment 9 Matthew Barnes 2008-03-16 18:34:35 EDT
RHEL 5.2 will re-base Evolution from version 2.8.0 to version 2.12.3.
Can you please test whether this bug is still present in RHEL 5.2?
Comment 10 Subhendu Ghosh 2008-03-17 00:12:43 EDT
Will try - have been using TB for a while now.
Comment 12 RHEL Product and Program Management 2008-06-17 12:27:14 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.