This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 227803 - Compilation of "compiz" fails because "kde window decorator" is not disabled
Compilation of "compiz" fails because "kde window decorator" is not disabled
Status: CLOSED DUPLICATE of bug 234128
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-08 05:28 EST by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-29 12:12:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2007-02-08 05:28:44 EST
Description of problem:
When building "compiz" on a system on which not only the "GNOME" development
packages but -also- the "KDE" ones are installed, the compilation fails in the
"KDE" part because of allegedly missing headers.

Version-Release number of selected component (if applicable):
compiz-0.3.6-2.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Recompile "compiz-0.3.6-2.fc7" source package.
  
Actual results:
Compilation fails first because some "KDE" headers are not found. After setting
"CPPFLAGS" accordingly, compilation aborts again because "dbus/connection.h"
appears to be missing, whereas only "dbus/dbus-connection.h" does exist.

Expected results:
Binary packages are built correctly from "compiz-0.3.6-2.fc7.src.rpm".

Additional info:
There are no "KDE" related entries in the "spec" file which indicates, that
building the "KDE" related portion is not desired anyway. However, the "compiz"
configure script detects the presence of "KDE" development packages on the build
system and wants to build the "KDE" window decorator unless this module is
explicitly disabled during the "configure" step. It thus seems that
"--disable-kde" is currently missing from the "spec" file.
It would be rather preferrable of course to actually add a "KDE" subpackage
including the corresponding decorator module. Until this is the case, the "KDE"
module should get disabled.
Comment 1 Kristian Høgsberg 2007-03-29 12:12:16 EDT

*** This bug has been marked as a duplicate of 234128 ***

Note You need to log in before you can comment on or make changes to this bug.