Bug 22796 - isdncdtrl addif ipppo can not add interfac
Summary: isdncdtrl addif ipppo can not add interfac
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: isdn4k-utils (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-24 03:01 UTC by Knut J BJuland
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-29 07:26:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Knut J BJuland 2000-12-24 03:01:26 UTC
/sbin/isdnctrl addif ippp0 is unable to add this interfac. isdnctrl complai
that kernel-isdn is newer than isdn4k-utils and stop running. Beacuse of
this I unable to use isdn-config to connect to the internet. I am using
kisdn. kernel-2.4.0-0.43.11

Comment 1 Ngo Than 2000-12-28 14:31:15 UTC
Could you please send me a part of /var/log/message (only infos from isdn) and
error messages.

Which isdn card do you have?



Comment 2 Knut J BJuland 2000-12-28 20:25:19 UTC
Isdn appear to be loaded. hisax run succesful and dectect and use Teles 16.3c
pnp. error messaege can't locat module ippp0. I am using kernel-2.4.0-43.11.
kisdn can conncet via isdn to internet, then the card must be configured right.
isdn-config complains about missing ppp support in kernel. I am using a
pre-compiled kernel 2.4.0-0.43-11.

isdn.log
Dec 23 17:52:15 2000|+4755316549     |+4781007007     | 1040|    103901|
977590335|   -1|O| 16|   1785258|    363712|3.2|7|0|0.12|DEM|0| 33| -1|
ippp0 added
EAZ/MSN for ippp0 is 55316549
Layer-2-Protocol for ippp0 is hdlc
Layer-3-Protocol for ippp0 is trans
Encapsulation for ippp0 is syncppp
Hangup-Timeout for ippp0 is 840 sec.
Callback for ippp0 is off
Callback delay for ippp0 is 3 sec.
ippp0 bound to 0
Version of kernel ioctl structs (6) does NOT match
version of isdnctrl (5)!
Kernel-Version newer than isdnctrl-Version, terminating.
GET A NEW VERSION OF isdn4k-utils.

from isdnctrl

(ISDN subsystem with ISDN_MAX_CHANNELS > 16 detected - 2 active channels, 3
MSN/SI entries)
(Data versions: iprofd=0x06  net_cfg=0x06  /dev/isdninfo=0x01)
isdn_net_ioctl_cfg version mismatch (kernel 0x06, isdnlog 0x05)
exit now 99


log.

Dec 28 21:03:16 knut isdn: Loading ISDN modules succeeded
Dec 28 21:03:17 knut isdn: isdnlog startup succeeded
Dec 28 21:03:17 knut isdn: Adding provider 'Nextra' on device 'ippp0' succeeded
Dec 28 21:03:26 knut isdn: isdnlog shutdown failed
Dec 28 21:03:26 knut isdn: ipppd shutdown failed
Dec 28 21:03:26 knut ifconfig: ippp0: unknown interface: No such device
Dec 28 21:03:26 knut isdn: Removing provider 'Nextra' on device 'ippp0' failed
Dec 28 21:03:27 knut isdn: Unloading ISDN modules succeeded



Comment 3 Knut J BJuland 2000-12-29 07:26:36 UTC
I have a Teles 16c PNP isa isnd card. It is supported in linux.

Comment 4 Ngo Than 2001-01-04 19:51:11 UTC
You should update the new isdn4k-utils-3.1-34, isdn-config-0.18-9 and
kernel-2.4.0-0.43.12
on your machine. It should work. I have the same hardware,  it works for me with
this configuration. 



Note You need to log in before you can comment on or make changes to this bug.