Bug 227995 - bind-chroot-admin very broken
bind-chroot-admin very broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
Ben Levenson
:
: 228276 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-09 07:57 EST by Florian La Roche
Modified: 2013-04-30 19:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: 9.3.4-7.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-26 06:38:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2007-02-09 07:57:04 EST
Description of problem:

The newest change to bind-chroot-admin is very broken:


[root@knorke /]# BIND_CHROOT_PREFIX=`grep "ROOTDIR" /etc/sysconfig/named |grep \"`
[root@knorke /]# echo $BIND_CHROOT_PREFIX
# ROOTDIR="/some/where" -- will run named in a chroot environment.
[root@knorke /]#                                                             


Why not source the file or at least do a ^ROOTDIR search?

regards,

Florian La Roche


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Tkac 2007-02-09 10:27:24 EST
Could you please test bind-9.3.4-6.fc7 and send me results? Thanks, Adam
Comment 2 Adam Tkac 2007-02-12 09:32:19 EST
*** Bug 228276 has been marked as a duplicate of this bug. ***
Comment 3 Florian La Roche 2007-02-12 09:38:32 EST
This still looks very broken. Nearly the same code is a few lines below in
the function "rootdir()" and that code is sourcing the file to use the data.

This part of bind had so many problems, we should simplify and cleanup the code,
not add more confusion here.

Setting again to assigned, we should clean this up some more.

Thanks,

Florian La Roche
Comment 4 Adam Tkac 2007-02-23 11:32:50 EST
(In reply to comment #3)
I've built bind-*9.3.4-7.fc7 . I think script is fine there. You could check it
and write comment or close this bug

Regards, Adam
Comment 5 Florian La Roche 2007-02-24 11:47:24 EST
-7 didn't show up in rawhide, but the code in cvs looks good to me.

Thanks for working on the chroot bits,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.