Bug 227998 - add/remove software fails to connect, only firefox connects, nothing else!
add/remove software fails to connect, only firefox connects, nothing else!
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-09 08:45 EST by Rory Renton
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-05 11:59:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rory Renton 2007-02-09 08:45:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
not limited to pirut, basicly anything that uses internet minus firefox.

   1. I have Fedora 6 64bit, on amd, with nvidia mainboard and graphics, internet through router (that works on windows)
   2. I couldn't really access internet until I disabled ipv6, as in update, pirut, email and IM all failed to connect, and firefox only displayed a couple of pages eventualy. after I disabled ipv6 it worked only with firefox, NOTHING else works.
   3. even tryed using a non-nvidia ethernet card
   4. but I can still only get access to internet via firefox or ping, nothing else seems to work (eg yum, that would be nice, or email, or even just gain!)



Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.intall FC6, even clean install.
2.
3.

Actual Results:
[root@localhost ~]# yum search wine
Loading "installonlyn" plugin
Setting up repositories
Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mi...e-6&arch=x86_64 error was
[Errno 4] IOError: <urlopen error (110, 'Connection timed out')>
Error: Cannot find a valid baseurl for repo: core

Expected Results:


Additional info:
I'm a linux newbie, but I have installed twice, and the internet works fine in windows (dual booting), its through a router so I see no reason at all!

this is for everything minus firefox (since I disabled ipv6)
Comment 1 Rory Renton 2007-02-11 08:54:00 EST
ok, figured out allot about this bug.

I have eventualy been able to work around it by using ping command to resolve
the ip addresses of domain names used in evolution, Gaim and yum. and replace
them in there configs.

now everything works to some degree, so this proves that its a DNS lookup problem.

I have now been able to update FC6 using my bodge/work around, and it still has
the problem. although, once it did download mail in evolution using a domain
name instead of an IP, but haven't been able to repoduce :S
Comment 2 Rory Renton 2007-02-13 09:00:02 EST
ok, installed FC5, it also has the problem, but not for yum, and firefox you
need to disable ipv6 to see anything this century.

so on FC5 anything like Gaim, evolution, etc, you need to type an IP not a domain.

so its a BIG problem.
Comment 3 David Cantrell 2007-02-14 11:19:33 EST
It sounds like you lack correct DNS information.  Can you tell me how you
configured the Ethernet interface?  That will help try to reproduce things here.

Also, if you can try Fedora 7 Test 1, that would also be really helpful.

Thanks.
Comment 4 Rory Renton 2007-02-14 12:08:52 EST
will do, in win-crap at the moment. once I'm back in FC5 I will (latter today)

erm, don't think I will install FC7, FC6 had enough bugs, and thats not a beta.
also 3 installs in a week is to much.

Comment 5 David Cantrell 2007-03-05 11:59:44 EST
The behaviour you are describing is very indicative of an incorrect
/etc/resolv.conf file.  You need to add nameserver lines for each of your ISP's
nameservers (or company, or home, or whatever).  Sometimes people using DHCP are
expecting the DNS information to be fed via the DHCP request.  This usually
works, but not always because not all DHCP servers are created equal.

If you get an IP address (check by running /sbin/ifconfig and then pinging a
known host), go and check the contents of /etc/resolv.conf (cat
/etc/resolv.conf).  If resolv.conf is empty, you need to manually set your DNS
info by editing that file and writing nameserver lines in this form:

nameserver a.b.c.d
nameserver e.f.g.h

Where the part after the nameserver keyword is the IP address of the nameserver.
 Save and exit, and then see if normal network activity returns.

A lot of office and home routes by companies like Linksys and Netgear have
incomplete or bogus DHCP servers that fail to hand out correct DNS information.
 Sometimes it works, sometimes it doesn't.

Closing this as not a bug because I have failed consistently to reproduce it
here and your report really does sound like you're missing the contents of
/etc/resolv.conf.

Note You need to log in before you can comment on or make changes to this bug.