Bug 22801 - objdump spurious error in find-requires.
objdump spurious error in find-requires.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
: 41372 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-23 23:59 EST by Sam Varshavchik
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-22 15:09:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2000-12-23 23:59:53 EST
Getting a bunch of errors like this:

Finding  Requires: (using /usr/lib/rpm/find-requires)...
objdump: /var/tmp/courier-install/etc/init.d/courier: File format not
recognized
objdump:
/var/tmp/courier-install/usr/lib/courier/libexec/authlib/authdaemond: File
format not recognized

This is why:

[mrsam@localhost rpm]$ file
/var/tmp/courier-install/usr/lib/courier/share/esmtpd
/var/tmp/courier-install/usr/lib/courier/share/esmtpd: Bourne shell script
text executable


The grep in find-requires now thinks that this is a binary executable.
Comment 1 Sam Varshavchik 2001-01-13 18:50:04 EST
This problem still exists in beta2.
Comment 2 Jeff Johnson 2001-02-21 14:11:21 EST
Changing component.
Comment 3 Jeff Johnson 2001-03-23 11:09:42 EST
The root cause for the problem is a change to /etc/magic in the file package
that
broke logic in find-requires. FWIW, the error message is harmless.
Comment 4 Jeff Johnson 2001-05-22 14:58:33 EDT
*** Bug 41372 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Johnson 2001-06-06 13:37:59 EDT
Fixed (by more carefully qualifying file(1) output) in rpm-4.0.3-0.32.
Comment 6 eric gerbier 2001-07-16 11:40:29 EDT
I solve the problem in rpm-build-4.0.2-8, with a little change in
/usr/lib/rpm/find-requires :
my new line 9 is :

exelist=`echo $filelist | xargs -r file | grep ":.*executable" | grep -v script
| cut -d: -f1 `

Note You need to log in before you can comment on or make changes to this bug.