Bug 228040 - cpio in /usr/bin conflicts with redhat-lsb and isn't FHS-compliant.
cpio in /usr/bin conflicts with redhat-lsb and isn't FHS-compliant.
Product: Fedora
Classification: Fedora
Component: cpio (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2007-02-09 12:48 EST by James Wilkinson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-02-19 04:04:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Wilkinson 2007-02-09 12:48:57 EST
Description of problem:
New cpio package conflicts with redhat-lsb

Version-Release number of selected component (if applicable):
cpio.i386 0:2.6-24.fc7

How reproducible:
Steps to Reproduce:
1. yum update cpio
Error: Missing Dependency: /bin/cpio is needed by package redhat-lsb

Additional info:
Downloading the package and rpm -qlp'ing it shows that cpio has moved to /usr/bin.

I can't quickly confirm that LSB requires cpio to be in /bin -- but the FHS does.
http://www.pathname.com/fhs/pub/fhs-2.3.html#BINESSENTIALUSERCOMMANDBINARIES says:

   The following programs, or symbolic links to programs, must be in /bin if the    
   corresponding subsystem is installed:

   Command	Description
   cpio	        The cpio archiving utility (optional)
Comment 1 Peter Vrabec 2007-02-19 04:04:18 EST
fixed in 2.6-25

Note You need to log in before you can comment on or make changes to this bug.