Bug 228115 - Audacity crashes when recording from vinyl
Audacity crashes when recording from vinyl
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-09 21:02 EST by Erick Omar Delgado
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-05 18:44:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erick Omar Delgado 2007-02-09 21:02:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.0.9) Gecko/20070131 Fedora/1.5.0.9-2.fc6 Firefox/1.5.0.9 pango-text

Description of problem:
When I record a vinyl with Audacity it crashes every time when recording.  All apps are closed before running Audacity.

Version-Release number of selected component (if applicable):
audacity-1.3.2-4.fc6

How reproducible:
Always


Steps to Reproduce:
1. Launch Audacity and click on the microphone icon under the recording level
2. Click on the record icon and start the vinyl and let the vinyl play until it finishes.
3.

Actual Results:
[erick@localhost ~]$ audacity 
The program 'audacity' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 11299502 error_code 1 request_code 0 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
The program 'audacity' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 11299505 error_code 1 request_code 0 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[erick@localhost ~]$ 


Expected Results:


Additional info:
Comment 1 Gérard Milmeister 2007-02-10 06:34:39 EST
Can you produce the crash for other operations? It doesn't seem to have anything
to do with the audio part.
Comment 2 Erick Omar Delgado 2007-02-10 10:53:15 EST
(In reply to comment #1)
> Can you produce the crash for other operations? It doesn't seem to have anything
> to do with the audio part.

I did produce the crash again.  I opened up Audacity via terminal and opened up
RealPlayer and I proceeded to record a stream from www.orbitalgrooves.com.  I
let is record until lik 11min. and it crashed.  Below is the results...

[erick@localhost ~]$ audacity
The program 'audacity' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 11258019 error_code 1 request_code 0 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
The program 'audacity' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 11258022 error_code 1 request_code 0 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[erick@localhost ~]$ 
Comment 3 Gérard Milmeister 2007-02-10 17:33:25 EST
I cannot reproduce this behaviour.
Anyway this is an X error, maybe related to drawing the wave during a long
recording...
Please report this upstream.
Comment 4 Erick Omar Delgado 2007-02-11 19:04:18 EST
(In reply to comment #3)
> I cannot reproduce this behaviour.
> Anyway this is an X error, maybe related to drawing the wave during a long
> recording...
> Please report this upstream.

May I ask how would I do this? 
Comment 5 Michael Schwendt 2007-02-16 07:27:08 EST
http://audacity.sourceforge.net/contact/lists
Comment 6 Per Nystrom 2007-02-20 11:23:10 EST
I got the same message while running gtk-gnutella.  Seems to me it's an X issue
in FC6.  I also notice that Firefox randomly quits; no error messages at all but
I suspect it's related.

The program 'gtk-gnutella' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 14963456 error_code 1 request_code 0 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
07-02-19 20:00:44 (WARNING): trapped foreign exit(), cleaning up...
Comment 7 Gérard Milmeister 2007-02-20 12:07:48 EST
It might be a problem with the chosen gtk theme. Try again with ClearLooks for
example.
Comment 8 Per Nystrom 2007-02-20 21:15:07 EST
Tried with ClearLooks, same problem.  I believe this is the same issue as in
these bugs, maybe someone wants to consolidate them?

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=222776
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=191575
Comment 9 Michael Schwendt 2007-02-26 20:17:32 EST
Somebody has reported this upstream, too:
http://limpet.net/audacity/bugzilla/show_bug.cgi?id=261
Comment 10 Devin 2007-03-05 11:55:40 EST
The bug referenced here:

    https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=222776

has been resolved.  Per suggested that this bug is related to the above
referenced bug.  Perhaps the cause for this bug is the same as the above
referenced bug.
Comment 11 Per Nystrom 2007-03-05 14:00:08 EST
Indeed, my problems have not recurred since I added

Load  "extmod"

back into the "Module" section of /etc/X11/xorg.conf as suggested in the other
bug.  I think it got removed by Nvidia's installer; proprietary graphics card
driver users beware.
Comment 12 Michael Schwendt 2007-03-05 14:06:47 EST
Can we get confirmation from the original reporter, please,
that the work-around from comment 11 also makes the problem
go away with Audacity?
Comment 13 Erick Omar Delgado 2007-03-05 18:36:14 EST
(In reply to comment #12)
> Can we get confirmation from the original reporter, please,
> that the work-around from comment 11 also makes the problem
> go away with Audacity?
> 
After adding Load "extmod" and doing a few operations with Audacity I did not
experience a crash while recording.  I was able to record a full vinyl album
(one side) which totalled around 20-22 min. and recorded a radio station for
about 30 min. and Audacity did not crash.  
While recording I was opening and closing and adding filters to a track and
Audacity did not crash.  Audacity did crash at one point when I was about to
record, but was not able to reproduce the behaviour at the moment.

I agree with Per (comment #11) about the nvidia driver installer.  It removes
every thing from the Module section of the xorg.conf except the Load "glx" module.

Thank you.
Comment 14 Michael Schwendt 2007-07-05 18:44:51 EDT
The quoted X errors are not related to Audacity and cannot
be fixed inside the Audacity packages. For other crashes during
recording with Audacity, open separate tickets and append a
backtrace.

Note You need to log in before you can comment on or make changes to this bug.