Bug 22826 - xdm/kdm - xinitrc infinite loop
Summary: xdm/kdm - xinitrc infinite loop
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-25 22:33 UTC by Sammy
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-25 22:33:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2000-12-25 22:33:49 UTC
Well, this took an hour on Christmas Day to track down!

The file /etc/X11/xinit/xinitrc.d/xinitrc needs to be in /etc/X11/xinit
instead!!!! BECAUSE /etc/X11/xdm/Xsession script runs all files in
/etc/X11/xinit/xinitrc.d directory BUT SO DOES xinitrc thus running
itself in a loop. Symptom is that logging in via xdm/kdm hangs.

Comment 1 Bill Nottingham 2000-12-28 19:26:24 UTC
It is not in /etc/X11/xinitrc.d as of xinitrc-3.3.


Note You need to log in before you can comment on or make changes to this bug.