Bug 228264 - Memory leak/OOM in jpilot
Memory leak/OOM in jpilot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jpilot (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-12 05:17 EST by Jan "Yenya" Kasprzak
Modified: 2008-02-08 10:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-08 10:30:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2007-02-12 05:17:19 EST
Description of problem:
When jpilot is left running after synchronization with Palm, it accumulates
enough memory to trigger OOM killer.

Version-Release number of selected component (if applicable):
jpilot-0.99.8-8.fc6.x86_64
Palm Tungsten T5
linux-2.6.20 (from ftp.kernel.org)

How reproducible:
Unsure, it happened twice so far on my computer: once the OOM killer has killed
the X server or window manager, so my whole X session was lost, the second time
I managed to run ps axm and kill the worst offender by hand (it was jpilot and
it had SIZE >= 2GB and RSS about 800M).

I use jpilot on this computer for regular synchronization only for a week or so.

Steps to Reproduce:
1. Run jpilot, configure it for your PDA
2. Connect the PDA via the USB cable, press the hotsync button on the cable
3. press the hotsync button in jpilot
4. wait till synchronization finishes and keep jpilot running (the OOM condition
has happened during the normal work once, and the second time it was when
jpilot has been running unattended over a weekend).
  
Actual results:
either the system starts thrashing, or an OOM killer triggers and kills some
process.

Expected results:
Jpilot should not use so much memory.

Additional info:
Sorry for the fuzzy report, I will add more when I find something interesting.
For now, I will run jpilot under "ulimit -v 200000". After startup, jpilot uses
about 160MB of memory:

USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
kas       7845  0.0  0.8 159428  9076 pts/25   S+   11:13   0:00 jpilot
Comment 1 Jan "Yenya" Kasprzak 2007-02-12 06:02:46 EST
OK, I can reproduce this - just use the steps described above, and after the
synchronization finishes, run

while sleep 5; do ps axu|grep jpilot|grep -v grep; done

and watch jpilot SIZE increase by ~120KB every 30 seconds or so (which is
probably  just a block size used by GNU malloc()) - the RSS increases continually:

USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
kas       7845  0.0  2.0 170996 20780 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171120 20800 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171120 20820 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171120 20840 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171120 20860 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171120 20876 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171120 20896 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171120 20916 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171244 20936 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171244 20956 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171244 20976 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171244 20992 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171244 21016 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171244 21032 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171368 21052 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171368 21072 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171368 21092 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171368 21112 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171368 21128 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171368 21152 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171492 21172 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171492 21192 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171492 21212 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171492 21232 pts/25   S+   11:13   0:01 jpilot
kas       7845  0.0  2.0 171492 21252 pts/25   S+   11:13   0:01 jpilot
Comment 2 Jan "Yenya" Kasprzak 2007-02-13 08:14:35 EST
Today I have compiled 0.99.9 from -devel, and it has the same issue. I have
found that the problem may be in displaying time - I had the time format set to
12:00:00 (incl. seconds). When I changed it to just 12:00 (w/o seconds), the
leak was much smaller (but still was there).

Since 0.99.9 is the newest release, I have reported it upstream:

http://bugs.jpilot.org/1789
Comment 3 Ivana Varekova 2008-02-08 05:23:34 EST
FC6 is no longer supported, there will be no further updates released for it,
could you please test whether this bug affects fc7,8 or devel branch?
Comment 4 Jan "Yenya" Kasprzak 2008-02-08 10:24:22 EST
It is OK in F8 (jpilot-0.99.9-3.fc7.x86_64).

Note You need to log in before you can comment on or make changes to this bug.