Bug 228282 - Pre requirements not added to Sqlite DB
Summary: Pre requirements not added to Sqlite DB
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-metadata-parser   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-12 15:01 UTC by Florian Festi
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 09:08:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
write pre requierement flags into the yum sqlite db (5.50 KB, patch)
2007-02-13 12:59 UTC, Florian Festi
no flags Details | Diff
adjusted patch to upstream coding style (5.53 KB, text/x-patch)
2007-02-14 14:33 UTC, Florian Festi
no flags Details

Description Florian Festi 2007-02-12 15:01:00 UTC
Description of problem:
yum-metadata-parser does not write the prerequirement flag into the cached yum
sqlite dbs (/var/cache/yum/*/primary.xml.gz.sqlite)

Version-Release number of selected component (if applicable):
yum-metadata-parser-1.0.3-1.fc6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum update (press n) to generate sqlite cache
2. sqlite3 /var/cache/yum/core/primary.xml.gz.sqlite
3. select * from requires where pre!="FALSE";
  
Actual results:
Nothing found

Expected results:
Lots of results (all pre requirements)

Additional info:
The upstream patch from 2006-07-10 added the needed db row but there is no code
for filling it, yet.

Comment 1 Florian Festi 2007-02-13 12:59:41 UTC
Created attachment 147985 [details]
write pre requierement flags into the yum sqlite db

That patch should fix the problem. Going to sent it to the upsteam mailing
list, too.

Comment 2 Florian Festi 2007-02-14 14:33:20 UTC
Created attachment 148052 [details]
adjusted patch to upstream coding style

already sent to upstream

Comment 3 Florian La Roche 2007-06-18 09:08:30 UTC
Looks like this is fixed in current -HEAD code, so closing this.

regards,

Florian La Roche


Note You need to log in before you can comment on or make changes to this bug.