Bug 22832 - sshd needs to check before running xauth
sshd needs to check before running xauth
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-25 23:58 EST by Bill Nottingham
Modified: 2014-03-16 22:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-20 14:24:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
check that xauth is there before running it (987 bytes, patch)
2000-12-25 23:59 EST, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2000-12-25 23:58:10 EST
On a system with no X installed, logging in via ssh with X forwarding
enabled displays:

sh: /usr/X11R6/bin/xauth: No such file or directory

Patch attached, salt to taste.
Comment 1 Bill Nottingham 2000-12-25 23:59:28 EST
Created attachment 6682 [details]
check that xauth is there before running it
Comment 2 Pekka Savola 2000-12-28 17:56:07 EST
The situation should not be silently ignored.  A better warning message would be in order though.
Comment 3 David Thiede 2001-04-20 14:24:50 EDT
This problem seems to still be in 7.1 release. At times the circuit is dropped
after seeing the message. I have not been able to identify the exact sequence
needed to characterize the conditions in which a drop happens or just the
message but the connect succeeds. The system that I connect to has none of the
XFree86 rpms installed but I see that DISPLAY=host.domain:11.0. that doesn't
seem right. I can also unset DISPLAY on the client side and the message no
longer appears.

The client systems that I have tested with are 7.0 with 2.2.17-14 and 2.2.16-22.
the ssh packages are 2.5.2p2. Due to the erratic nature of the dropped
connections, I would  elevate the priority and mark the severity.

Dave Thiede
Comment 4 Pekka Savola 2001-05-11 16:52:54 EDT
openssh-2.9p1-2 in Rawhide disables xauth in a more graceful manner if the xauth binary cannot be found.

Note You need to log in before you can comment on or make changes to this bug.