This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 228389 - daemon/automount.i needs rewrite for fedora
daemon/automount.i needs rewrite for fedora
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: initng-ifiles (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Malmgren
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-12 15:33 EST by Jason Farrell
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 02:21:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2007-02-12 15:33:29 EST
daemon/automount.i does not work on Fedora out of the box. Fedora's autofs
initscript sources the envvars in /etc/sysconfig/autofs and then calls
"automount $OPTIONS" where by default $OPTIONS is empty. the /etc/auto.* conf
files then define the mounts.

I have verified that the following automount.i works on my FC6 system. I needed
to add "forks;", move "system/modules/autofs4" from the use= line to need=
(otherwise the old 'autofs' module was loaded), and change "daemon
daemon/automount/*" to "daemon daemon/automount" since it's standalone. old
lines commented out below:



#!/sbin/itype
# This is a i file, used by initng parsed by install_service

# NAME:
# DESCRIPTION:
# WWW:

#daemon daemon/automount/* {
daemon daemon/automount {
        #need = system/bootmisc;
        need = system/bootmisc system/modules/autofs4;
        #use = system/modules/autofs4;
        #env TIMEOUT=30;
        #env_file = /etc/conf.d/automount;
        env_file = /etc/sysconfig/autofs;
        #env MOUNTPOINT=/mnt/${NAME};
        #env PIDFILE=/var/run/autofs.${NAME}.pid;
        env PIDFILE=/var/lock/subsys/autofs;
        #env CONFFILE=/etc/autofs/auto.${NAME};
        #exec daemon = /usr/sbin/automount --timeout ${TIMEOUT} --pid-file
${PIDFILE} ${MOUNTPOINT} file ${CONFFILE};
        exec daemon = /usr/sbin/automount --pid-file ${PIDFILE} ${OPTIONS};
        pid_file = ${PIDFILE};
        forks;
}
Comment 1 Daniel Malmgren 2007-02-13 02:21:28 EST
Thanks for your report. This has now been fixed in upstreams svn (thanks Ismael)
and will be included in the next release.

Note You need to log in before you can comment on or make changes to this bug.