Bug 228510 - Please update opencv to 1.0
Please update opencv to 1.0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: opencv (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-13 09:20 EST by Mary Ellen Foster
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-20 08:46:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mary Ellen Foster 2007-02-13 09:20:14 EST
Description of problem:

OpenCV 1.0 has been released since November, but the version in Extras is still
0.9.9. It would be good to update to the final version.

Version-Release number of selected component (if applicable):
opencv-0.9.9-4.fc6
Comment 1 Ralf Corsepius 2007-02-13 09:52:48 EST
(In reply to comment #0)
> OpenCV 1.0 has been released since November, but the version in Extras is still
> 0.9.9. It would be good to update to the final version.

1.0 is in fc7 since December ;)

Unfortunately upgrading fc6 is not easily doable, because opencv upstream had
chosen to break the SONAME between 0.9.9 and 1.0 
(0.9.9 ships lib*.0, 1.0 ships lib*.1)

i.e. an upgrade to 1.0 in FC6 would break package dependencies.
Comment 2 Simon Perreault 2007-02-13 10:01:39 EST
Can the bug be closed with NEXTRELEASE then?
Comment 3 Ralf Corsepius 2007-02-13 10:12:24 EST
(In reply to comment #2)
> Can the bug be closed with NEXTRELEASE then?

Not yet, because I am seriously considering to upgrade.
If and how depends on a couple of questions yet to be clarified.

Comment 4 Ralf Corsepius 2007-02-20 08:46:29 EST
(In reply to comment #3)
One week has passed, and despite a warning on the fedora-extras-list, nobody has
objected, nor insisted on a compat-opencv.

Therefore, I've taken the plunge and pushed a build of opencv-1.0.0 for fc6.

Package should appear with the next round of FE releases (SONAME breakages
guaranteed).

Note You need to log in before you can comment on or make changes to this bug.