Bug 22855 - Silicon Motion driver not installed in XFree86-4.0.2-0.1
Silicon Motion driver not installed in XFree86-4.0.2-0.1
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 23054 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-26 16:45 EST by Matti Airas
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-26 16:45:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested XF86Config-4 of my SMI setup (14.11 KB, text/plain)
2001-02-13 02:45 EST, Matti Airas
no flags Details

  None (edit)
Description Matti Airas 2000-12-26 16:45:24 EST
Silicon Motion drivers are not installed by XFree86-4.0.2-0.1.i386.rpm.
The following one-liner to the spec file fixes the problem:

--- XFree86.spec~	Tue Dec 19 19:04:22 2000
+++ XFree86.spec	Tue Dec 26 18:53:57 2000
@@ -996,6 +996,7 @@
 /usr/X11R6/lib/modules/drivers/rendition_drv.*
 /usr/X11R6/lib/modules/drivers/s3virge_drv.*
 /usr/X11R6/lib/modules/drivers/sis_drv.*
+/usr/X11R6/lib/modules/drivers/siliconmotion_drv.*
 /usr/X11R6/lib/modules/drivers/tdfx_drv.*
 %ifnarch ia64
 /usr/X11R6/lib/modules/drivers/tga_drv.*
Comment 1 Bill Nottingham 2000-12-28 14:28:36 EST
Fixed as of XFree86-4.0.2-0.2; will be in next rawhide release.
Comment 2 Bill Nottingham 2001-01-02 01:15:45 EST
*** Bug 23054 has been marked as a duplicate of this bug. ***
Comment 3 Preston Brown 2001-02-12 12:48:11 EST
Please note that this driver will not be used by default, the 3.3.6 driver
will.  This is because I have received reports that it doesn't work well.

If it does work, I need to know your:

1. PCI IDs for the chipset in question
2. a copy of your XF86Config-4

Send them directly to me, don't attach to this bug report, please.
Comment 4 Matti Airas 2001-02-13 02:45:59 EST
Created attachment 9880 [details]
Requested XF86Config-4 of my SMI setup
Comment 5 Matti Airas 2001-02-13 02:47:45 EST
> Please note that this driver will not be used by default, the 3.3.6
> driver will. This is because I have received reports that it doesn't
> work well.

On my laptop (HP OmniBook XE2-DC, 800x600 res. TFT), the 4.0.2 driver
works tremendously much better than the 3.3.6 one. The 3.3.6 driver
would from time to time refuse to init the HW correctly, forcing me to
keep Windows there just to init the chipset correctly! Furthermore,
suspends directly from X were out of the question.

Now, initialization works perfectly. The only glitch is that going to
standby crashes X (suspend works fine), but compared to the problems
with 3.3.6, I have nothing to complain.

Oh, and for some reason RH7 installation had to be performed in text
mode, since no valid video modes could be found. Furthermore,
hard-coding vertical refresh rate to 60 Hz would not work, so I set it
to 50-70 Hz. Go figure. The problem appeared with both with 3.3.6 and
with 4.0.2.

> 1. PCI IDs for the chipset in question

lspci -v gives:

01:00.0 VGA compatible controller: Silicon Motion, Inc. SM710 LynxEM
(rev a3) (prog-if 00 [VGA])
Subsystem: Hewlett-Packard Company: Unknown device 000e
Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 10
Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
Capabilities: [40] Power Management version 1

scanpci -l gives:

pci bus 0x1 cardnum 0x00 function 0x0000: vendor 0x126f device 0x0710
Silicon Motion Inc. LynxEM
CardVendor 0x103c card 0x000e (HP, Card unknown)
STATUS    0x0230  COMMAND 0x001f
CLASS     0x03 0x00 0x00  REVISION 0xa3
BIST      0x00  HEADER 0x00  LATENCY 0x40  CACHE 0x00
BASE0     0xfd000000  addr 0xfd000000  MEM
MAX_LAT   0x00  MIN_GNT 0x00  INT_PIN 0x01  INT_LINE 0x0a
BYTE_0    0x6010001  BYTE_1  0x00  BYTE_2  0x806cfd0  BYTE_3  0xffffffff

I am not quite sure what the PCI ID you want is. If those are not
enough, please tell how to extract the info.

> 2. a copy of your XF86Config-4

Attached.

Note You need to log in before you can comment on or make changes to this bug.