Bug 228551 - Install hangs
Install hangs
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-13 14:08 EST by Andrig Miller
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-25 17:42:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrig Miller 2007-02-13 14:08:54 EST
Description of problem:

The installation hangs after specifying the type of install on the command line,
and entering the first text mode screens to specify language, IP configuration,
etc.  I am booting from a USB key (this server does not have a floppy or CD-ROM)
on an new spin of the Fedora diskboot.img (updated January 11, 2007), and the
boot works fine.  I am specifying linux askmethod from the initial screen, or
linux text askmethod (both hang), and then  it successfully starts up, and I get
the screens saying "Loading SCSI Driver", and then Loading SATA (sata_sil), then
usb-storage driver, and then I get the text mode "Choose a Language" screen.  I
press enter to pick english, and then I get the "Keyboard Type screen, and I hit
enter again to pick us, then I get the "Installation Method" screen, and I pick
HTTP.  I then get the "Networking Device" screen, and I select the eth0 (there
are eth1 and eth2 devices listed as well, but they are not connected). eth0 is a
Broadcom NetXtreme BCM5704 Gigabit Ethernet device.  I press "OK", and then I
configure TCP/IP using the dynamic options, enabling both IPv4 and IPv6, and it
sends the request over, and everything works fine.  Then I enter my HTTP site
information (I set up the latest FC6 with the January 11th updates on another PC
I have on the network).  I says retrieving the image file (different based on
text or graphical), and then I either get a blue screen with nothing, or I get
an X in the middle of the screen (the mouse can move), and nothing.

Just hung and doesn't do anything.

I can change to the various consoles and look around the file systems, /tmp,
/tmp/ramfs and see the install log, and the X.log if I choose to try the
graphical install.



Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1. Boot for install.
2. Enter initial information for installation.
3. Hang!
  
Actual results:

Hangs.


Expected results:

Should proceed to installation screens.

Additional info:

The anaconda.log file only has two errors in it, which I would expect.  It says
there is no floppy and that there is no cdrom, which both of those are true,
hence why I am booting from a USB key (128MB in size), and doing an HTTP based
installation.
Comment 1 Andrig Miller 2007-02-13 14:10:50 EST
I forgot.  I also looked through other similar bugs, and based on one of the
others I did disable ACPI in the bios, as well as APM.  Neither of those
workarounds worked for me.
Comment 2 Andrig Miller 2007-02-14 20:17:56 EST
After more trial and error, I am no further along with getting an installation.
 However, SLES 9 is still installed on this server, and it does boot.  After
looking at the boot messages, it turns out that the SLES 9 installation is using
a proprietary driver for the SATA RAID controller.  I also found some data that
said many of these SATA RAID chips don't implement hardware RAID, even though it
appears that way from the BIOS setting.  The driver actually has the RAID
capabilities.

Does anyone know if this is true for the Silicon Image 3114 integrated 4-port
chipset?

I'm not really sure whether this is a real issue or not though, because after
the sata-sil and libata kernel modules load, the two sata links are up, and the
two hard drives appears as SCSI devices and it can see the partitions on the
drives correctly, just like when I boot in SLES.  
Comment 3 Andrig Miller 2007-02-15 12:11:42 EST
I changed the component to dmraid, but I'm not sure if this is correct.  I did
find out that the Silicon Image 3114 chipset doesn't actually do hardware RAID,
and that the driver is responsible for RAID.  Given that, and the fact the all
the dm_* modules load, yet the install hangs, I am assuming that the dmraid
stuff is not working with this chipset.

The reason I believe this to be the root cause of the installation hanging, is
that the next step of the installation should be to look for current
installations and copy the installation image to the hard disks.

Any help here is greatly appreciated.
Comment 4 Andrig Miller 2007-03-31 10:17:40 EDT
I have done some more testing with this setup.  If I disconnect one of the two
SATA hard drives the installation no longer hangs, and works perfectly.  It
doesn't matter which one I disconnect.  I was able to install to both hard
drives with the other disconnected.  I also tried another SATA controller, and
disabled the motherboard SATA controller, and got the same results.  I could
install to one hard drive if the second was disconnected, but the installation
would hang if both drives were connected to the controller.  One final note.  I
found out through inspection that the two hard drives are not the same size. 
One is smaller than the other.  This could be the root of the problem, but I'm
not sure.  I was contemplating trying to buy another hard drive that match the
size of the larger one, and see if that cleared things up, but haven't gotten
around to it yet.
Comment 5 Don Koch 2007-04-05 18:23:58 EDT
I had a similar problem, although from a DVD install where it would hang at the
same place and found the following workaround.

Try booting with: linux irqpoll
Comment 6 Andrig Miller 2007-04-06 05:51:08 EDT
I'll give that a try, and see if it makes a difference.
Comment 7 Andrig Miller 2007-04-16 17:31:17 EDT
I tried to install using the irqpoll kernel parameter, but it still hangs at the
same point.

Note You need to log in before you can comment on or make changes to this bug.